XojoScript crash on Windows

Hello, I have a problem on some Windows (10 or 7 or server 2016) with an application that uses XojoScript, compiled Xojo2019r1.1

The program crashes on this line of the script, exactly
dim wstt as string = Format(0.,“0.00”)
or this (I’ve tried too)
dim wstt as string = Format(0.0,“0.00”)

This happens with one or two clients, out of hundreds.

On a Mac, no problem

Someone would have any idea ?
Thank you
Marc

Do you have the hardware specs for the machines in question?

Processor, system manufacturer, are they in a vm or remote session.

Sounds like „regional“ Settings. Is it possible that those PCs in questions are using different language and regional settings?

2 Likes

I do recall unexpected bad behaviors from Xojo and plugins for some specific places/cultures/languages in Earth in the past. :thinking:

2 Likes

Why not just 0 and leave it to format?

dim wstt as string = Format(0,“0.00”)

Thanks.
Two machines are VMWare virtual machines (W7 or server 2016) on a Fujistsu Xeon TX2550
but there is real machines on Window 10 that crashes also
The regional settings are same of mine or others
Until then I have always managed to get around Xojo’s problems…
Format(0,“0.00”) crashes also

What edition and version of vmware?
What is the hardware of the W10 machine and is xojo running on the bare metal or in a vm on that machine?

Could you download coreinfo and run this in the environment where xojo fails and post the results?

Here the results of coreinfo (no way to select or copy the text…)
Coreinfo1
Coreinfo2

Thanks

Was that from the vm machine running server 2016? If so, did you manage to find out what version of vmware its running?

After you let us know what those versions are, could you then check the bios versions of the machines with a problem.

Lots of questions I know, but I’ve checked those coreinfo reports and you have an identical set of features to the xeon I have in the other room apart from one entry, “DS Implements memory-resident debug buffer” which you have and I don’t. I don’t think this will cause the issue you’re seeing as I have another cpu here with that feature on that doesn’t have any issues using xojo script. So we’ll have to start narrowing it down to an out of data bios or an old version of vmware and if the w10 machines have the issue and they don’t run in a vm or in a remote session then I’d check the bios’ are up to date on those too.

vmware version is 6.0.u3

We see the same crash on a new PC HP, with W10 up to date

How do you get the bios version ?

If its an TX2550 M4 then that is ok for that machine, if its an M5 then its not certified.

Are you able to run coreinfo on that machine too? This will run it and create a textfile on the desktop with the output:

coreinfo.exe > %userprofile%\desktop\coreinfo.txt

Taken from the D3386 BIOS Setup Utility for FUJITSU Server PRIMERGY TX2550 M4/5 Reference Manual

  • Start the system and wait until the screen output appears.
  • Press the [F2] function key.
  • If a password is assigned, enter this password and confirm with the [Enter]
    key.
    The BIOS setup Main menu will be displayed on the screen.
  • To show system specific information select System Information and press
    the [Enter] key.
    The BIOS release information will be displayed:
    – BIOS release (e.g. Version R1.3.0)
    The number of the system board (e.g. D3386-B1) you will find under
    Board.
    – Press the [F1] function key.
    The General Help information will be displayed.

You could probably perform this remotely by using an app such as CPU-Z

or msinfo32 (start>run>msinfo32)

image

or typing

wmic bios get smbiosbiosversion

in a command prompt.

But doing all this in a vm will only work if vmware passes that through to the vm, if it doesn’t you’ll probably see the vm’s “fake” bios version.

You’ll then need to check that against the bios’ on the fujitsu site here https://support.ts.fujitsu.com/

Click Select a new Product >> on the right, click Product Search and type in TX2550, select the M4 (if its that) or M5 then navigate you way to the bios. The M4’s latest bios is D3386-A1x.R1.46.0 but I wouldn’t get into patching that as their IT guys should really do that after backing everything up (if its a system critical server).

I’m assuming you’ve already tried a script with just your call to Format, so to try to diagnose the problem I would first try a script that uses Doubles but doesn’t use Format. For example:

Sub Baz(d as Double)
End Sub
Baz(0.0)

and if that doesn’t crash:

Dim s As String = Str(0.0)

One bug with similar symptoms that happened in the past is that the XojoScript JIT selected floating point instructions that weren’t actually supported by the host machine.

1 Like

it crashes on the call Baz(0.0)

yes I’ve tested with the only line Format…

and the BIOS version : SMBIOSBIOSVersion 6.00

Ah yes, that’s the one reported by vmware, you’ll need to reboot the machine into the bios to check it (if you are local to the machine) or ssh into vmware on the barebones of the vm and run a tool to find that out.

I can’t, the machine is at my customer’s far from here, until then I access it through TeamViewer.
And my client is not a computer scientist…

and the machine is : TX2550 M4 XeBronze 3106

According the docs, the server has a built in web based admin console where you can gain baremetal access remotely so you could technically bounce off the teamviewer on another machine on their lan then control the server via that computer. See Advanced Video Redirection (AVR) in https://sp.ts.fujitsu.com/dmsp/Publications/public/ds-irmc-s5-en.pdf

You could probably use this to check the bios remotely if they will allow you to reboot the server and hit F2 during boot or the web based tool might allow you to just see the current bios version without rebooting.

Also, could you post the coreinfo and bios info from the W10 machine that is also showing this problem?

Also, you might want to start a feedback ticket going for this as it seems like an issue with XojoScript. If the chip is reporting that it can perform a feature and an error in the bios or vm host doesn’t allow the feature to work, XojoScript should really handle that as the Xojo framework/IDE does because you don’t see the a built app or the IDE falling over when passing a double to a function.

If feedback://showreport?report_id=43221 is the ticket regarding this issue then it doesn’t bode well that its 4.5 years old and still unresolved.