XojoConsoleFramework32.so libraries not found

Hi, I am uploading a new version of my Web Edition CGI app to my CentOS host and the app will not run. It was previously built with Xojo 2014r1 but now with Xojo 2015r2.2. I have used the ldd command to check the libraries but get the following when using ldd on the XojoConsoleFramework32.so library (all the others are OK):

linux-gate.so.1 =>  (0x00730000)
libgobject-2.0.so.0 => not found
libgthread-2.0.so.0 => not found
librt.so.1 => /lib/librt.so.1 (0x00dc6000)
libglib-2.0.so.0 => not found
libpthread.so.0 => /lib/libpthread.so.0 (0x0035a000)
libdl.so.2 => /lib/libdl.so.2 (0x004f6000)
libm.so.6 => /lib/libm.so.6 (0x007fe000)
libc++.so.1 => /home/devsca/public_html/scgi-bin/SCA/SCA Libs/./libc++.so.1 (0x004fb000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x009c1000)
libc.so.6 => /lib/libc.so.6 (0x00828000)
/lib/ld-linux.so.2 (0x00b05000)

I have used

yum install lib glib and
yum install libicu.1686

to install these packages and still no luck. Can anyone please help? I don’t know what else to do.

Question wich CentOS Version?

check if this helps:

yum install glib2.i686
libglib-2.0.so.0 => not found

-> shows that glib2 is not found. (32Bit)

Thanks very much Ren, that has fixed the not found errors, but my app will still not launch. After installing glib2 I restarted the server just in case. When I launch the app using the browser the progress bar starts but then stops and makes no further progress. I have checked the messages in /var/log and there isn’t anything obvious. Do you have any ideas that could help?

Problem solved! Somehow the build setting for the Port was set to 80 instead of Choose Automatically. The app is now up. Thanks for your help!