Xojo2023r3: problem copying class from Xojo2018

Mac OSX Ventura: having both versions of Xojo open, copying class from Xojo2018 into Xojo2023r3 by dragging from one workspace to the other, closing Xojo2018, then closing Xojo2023r3 and saving project with extension .xojo_project.
Upon subsequent opening of Xojo2023r3 project I get the dialog with title Missing Files, the message is “Unable to open project correctly. The project refers to files that could not be located or opened properly.”
When I click on the OK button (there is nothing else anyway on this dialog) I get another dialog with OK button stating: “One or more items (controls, properties, events, etc) are no longer supported in this version of Xojo. Saving will remove these items.”

How on earth I can port this class if I can’t get it to open? Do I need to create brand new class and then add all the controls and methods mimicking the Xojo2018 class? This is so painful.

Needless to say, I have lost few hours of work already fixing bad code and saving this class (Analyze menu was not showing any errors except of couple of warnings) yesterday just to find out today that I can’t have Xojo open this class anymore.

Ps. since I use Git I could restore the original project files so at least I am back to starting point. Any suggestions?

Maybe I missed the information but are you working on a Desktop project or Web project?

Have you just tried opening the existing project in 2023r3. Then just drag it from one project to another.

1 Like

Sorry, I didn’t mention, it is web app.

I haven’t tried cloning 2018 project and opening in 2023r3 to then copy selected classes, I will try tonight though I don’t think this will make a difference. If it works, I will certainly be happy and share the good news.

Too many changes from Web1 to Web2 (Xojo 2018 - Xojo 2023) that is better to recreate things instead of trying to drag/copy/paste.

It will not work, sorry.

Ah, didn’t realise that this was a web project.