Xojo2016r2 crashes suddenly

A week or 2 ago I installed Xojo2016r2. I was able to write and run my code without any problem. I was a happy user…till this afternoon.

At work I use also Xojo2016r2. Did write and run the code the whole day. No problem. Code did work at home and at work without any problem.
This afternoon I got home, connected my external disk to my PC, started the PC and started the code in Xojo IDE. Sofar no problem. Till…I tried to run the code…Xojo does compile without problem till the last part, then a fatal error occurred which needs to shut down Xojo. It asks if I want to report it, I answered yes (after the 4th crash, I am not so fast convinced that it is to blame the IDE) and…nothing happens.
After the 4th crash I un-installed Xojo206r2 successfully, restarted my PC and installed 2016r2 again. Bad luck, same result when I tried to run the code in the IDE. I started to blame my disk that it was corrupted. Checked the disk, the code and everything seems fine.
Then…I un-installed 2016r2 again, restarted the PC and installed 2015r4.1. I loaded the code…I started again to run the code in the IDE and…it runs!!! Like nothing happened.

How is it possible that 2016r2 runs like a champ for 2 weeks and then suddenly crashes time after time. I did shutdown the applictaion normally the last time I used it. I did shutdown the PC normally. I really have no clue why 2016r2 does not want to run my code anymore and I am back on 2015r4.1 which does run the code wihtout problem.

On the contrairy, 2016r2 does not want to run any code anymore, I tried also code from another project saved on another disk…also fatal errors… :frowning:

Help me. A confused user.

Did you clear the caches? I don’t know where they are stored on Windows, but I believe that each Xojo version has a separate cache file, so that might be a logical explanation.

Users\\appdata\roaming\xojo

Nuke the folder for the current release.

Rob,

Right-Click Xojo 2016r2 icon (in the desktop) and select the option to open the original folder.

Sorry: like Jim, I do not know where the Xojo Cache resides in Windows.

On OS X, the Xojo cache is in Library:Caches:Xojo.

I hope this help.

BTW: can you share the Caches:Xojo location when you locate it ?
(so the next time we can share that information).

Did you try to install Xojo 2016r2.1 ?
Release Notes: http://developer.xojo.com/2016r21-release-notes

I noticed the Windows IDE sometimes does crash. As I am using these days 2015R4.1 with Windows 10, I also got several crashes.

I became accustomed to hit Ctrl-S all the time.

I will try all these when I am home again, will keep you all posted…thanks already for the responses, I was not aware of any cache file…will jump on them :slight_smile:

For months I’ve been suffering IDE crashes on Windows.
It is irregular and I gave up about trying to guess why. It is always and the last phase of compilation, but it has an erratic repetition. Sometimes it happens at the first compilation, sometimes after two hours work. And with the last versions: 2015 and 2016. I can’t say when it began. I don’t remember.
I filed a feedback://showreport?report_id=41976 As you can see it was fixed and verified.
Probably that was the culprit at that moment. But now there are others. And I don’t feel like filing another case, because as I said there is no regular behaviour.

Ramon,

yes I think these questions can be silly, stupid, etc. But sometimes, the ost obvious is… forgotten.

Less usual:
Did you boot your PC, then run only Xojo ?
Did you boot your PC, set the Plane mode ON, then run only Xojo ?
Did you boot your PC in without fail, then run only Xojo ? (here, I do not know if Xojo can be run)

More usual:
Did you clear the Xojo cache ?
Did you use Xojo’s current version (2016r2.1) ?
Did you try to put your sources, the exe install xojo on an external mass storage (sd-card, external hd, etc.), fire Xojo and load the project from there ?
Did you try to put your sources, the exe install xojo on an external mass storage (sd-card, external hd, etc.) and try your project on another pc ?

These are the only test I recall, right now.

I suppose you’re running Windows 10.

I hope it is not true, but I do the same behavior as Ramon now, it crashes in the last part of the compilation :frowning:

Ok, I did

  • un-install Xojo2016r2 completely, and did check if the Xojo directory in c:\program files (x86) was gone.

  • I deleted the Xojo cache files in c:\users\\AppData\Roaming\Xojo (I did delete the complete directory)

  • re-installed Xojo2016r2 again in c:\program files (x86) …failed, could not rename a file…cancel…rollback

  • reboot

  • install Xojo2016r2 again in in c:\program files (x86) …failed, could not rename a file…cancel…rollback

  • install Xojo2016r2 on c:\Xojo…that did run well and installation was completed

  • I opened my project in the GUI, no problem

  • I started the code in the IDE…compiling…compiling…last part of compiling…crashhhh :frowning:

So, Emile, I can say Yes on almost all your Less Usuals and can say Yes on all More Usual’s

It is still weird that this all happens suddenly. The PC at work does not show any problem. Windows-7 with Xojo2016r2.
PC at home suddenly started to have problems yesterday, when I reported it the first.

And as extra, Feedback did upgrade to new version yesterday too and does crash now too at my home PC, so I cannot report anything.

So, fallback to Xojo2015r4.1 at home and my code runs fine again

Thank you for the given paths.

Why notXojo 2016r2.1 ?

Sorry to read you have troubles.

If I remember, I will - back at home - copy my current (and large) project on a SD-Card and try it under Windows 10. I will report later (maybe tomorrow).

and btw, the new feedback tool does not crash under Xojo2015r4.1 :smiley:

Sorry for the confusion…it was Xojo2016r2.1, I thought I had r2, but my install directory shows r21

For Windows, you’d better stick with 2015r4.1 for the moment. It’s often been stated here already.

Good to know…thanks all for the replies