"Xojo was unable to connect to authentication server" error


I have a license to Xojo 2014 R1.1.

Until now I have installed it on one computer only.

I am trying to install Xojo on a second computer using the same license. But every time I try to go to Help > Sign In… to login in order to retrieve my licences, i get the error “Sign in error. Xojo was unable to connect to authentication server. Check your network settings and try again”.
I have checked everything, disabled the firewall etc but could not make the error go away.

I also downloaded the licence files from the server, input the correct email to activate them, but they do not seem to “last”. On application exit and restart the licenses vanish, they do not appear anymore in the Help > License keys… window.

What can I do?

Send an email to hello@xojo.com with these details. As soon as we have a minute, we’ll look at it. Just remember that it’s a holiday weekend in the US, so the response may not be instant.

Thank you, Greg, I sent the email.

FYI to anyone using an older release of Xojo that encounters this error- If you have tried manual activation and that did not “stick”, download a 2017 (or later) release and Sign In on that release, then launch your older release and Sign In. And of course if you have any questions or are still having this problem, please email me at hello@xojo.com.

My support license has expired. I didn’t renew it because I am stuck on 2014 r2.1 because two of my controls don’t work on newer versions of Xojo. (style grid which Einhuger is not going to update so I have to replace it). Just haven’t finished that effort.

Once I do I will renew and try to get to latest version.

Sooooo… I can’t connect to the license server and get this error… I am downloading 2017 but why would connecting with that version connect vs. the old version. Either it can connect or it can’t? Confused… meanwhile still downloading 2017.

This has to do with SSL. When we patched our servers for some of the vulnerabilities that have come up over the last few years, older IDEs no longer have new enough protocols to connect.

Ok but then how do I enter my license key for this old IDE?

I downloaded 2017 and it did connect but says “You have no current license keys”. Went back to old IDE and it still can’t connect.

I think you can download the licence through the website then install it through the app.

Yes just tried that and can add the license file manually. It then asks me to enter my email address.
I do that and then when I close the license screen I get a “fatal error occurred and the app must shut down”.
I tried it twice and same thing both times.

[quote=383244:@Tim Turner]Ok but then how do I enter my license key for this old IDE?

I downloaded 2017 and it did connect but says “You have no current license keys”. Went back to old IDE and it still can’t connect.[/quote]
Did you log in?

Hi Tim,

Unless these is some other issue, like if you are working offline, you should not need to do the manual activation (the file download). Simply Sign In to the 2017 IDE and ignore it telling you that you need a license, just Sign In. Then open the 2014 IDE and Sign In there. If this does not work for you, please email over at hello@xojo.com and I’ll troubleshoot with you to get it working.

Do you mean via the web browser? Yes I was logged in on the browser.
The login from the IDE does not work.

I did all that and it does not work. I will email you thanks.

Finally got it working with Alyssa’s help.
I had to delete the old license online and then re-add it in the old IDE Licenses… system. But to do that I had to download and install a newer version and just authenticate on that version to then force the older IDE to use the new licensing system.