Xojo Standalone WebApp on Win2016 Server won't start


on Win2016 Server I am constantly failing to start up XOJO Standalone Webapp. When I start it up in console (as admin, full priviledges), it quits instantly without any error message. When I create a service, I get this as EXIT Code.

[code]c:\Program Files (x86)\JAKOBSSYSTEMS Servicedesk>sc query servicedesk

SERVICE_NAME: servicedesk
WIN32_EXIT_CODE : 4294967295 (0xffffffff)

I’ve tried 32 Bit and 64 Bit without luck. Cross Check on Win7 Pro works perfectly. Also tried different ports in case of conflict but with no luck. What I am missing?

Have you looked in the event viewer? Have you tried dbgview ? You should get a lot of insights from both, especially dbgview. Look here for more details.

edit: this download link to the whole sysinternals suite is easier.

Mmm… just tried, but there’s nothing really interesting to see. As I said it starts and stops. Forgot to mention: Full patched Win2016 and latest Xojo Version. Project is already the simplest website w/o any plugins, just plain Xojo Controls placed on website.

Web apps typically as something like IISUser or something like that. Does the user have access to everything it needs?

FWIW, you may be able to debug this by using Run Paused, still letting IIS launch the app.

dbgview shows your IE log, not the webapp log. Start dbgview before the webapp. You can simply double click the webapp in Windows Explorer, you don’t have to start it from the console. (perhaps I am just stating the obvious, but here it goes anyway)

Next, I would try this: set the properties of the executable to “run as administrator”, or alternately provide an account and password in the properties of the service. The user account would be verified to have all the necessary accesses. I am not sure, but I think this is also what Greg suggests in his first sentence. Again, start dbgview before you start the webapp service.

Hi Louis and Greg, thank you both you for your answers.
Okay 2nd Try, this time starting per right click “run as admin” from Explorer:

00000001 0.00000000 [14872] shell\\osshell\\lmui\ tshrui\\dll\\shrengine.cpp(1487)\ tshrui.dll!00007FFEAC068800: (caller: 00007FFEAC0646A4) ReturnHr(55) tid(3648) 80004005 Unbekannter Fehler 00000002 0.00056873 [14872] shell\\osshell\\lmui\ tshrui\\dll\\shrengine.cpp(1487)\ tshrui.dll!00007FFEAC068800: (caller: 00007FFEAC0646A4) ReturnHr(56) tid(3648) 80004005 Unbekannter Fehler 00000003 1.00342023 [16460] ds\\security\\smartscreen\\common\\core\\src\\script_host.cpp(51)\\smartscreen.exe!00007FF7086A5697: (caller: 00007FF7086A5DD8) Exception(7) tid(2b98) 80070001 Unzulssige Funktion. 00000004 1.00342023 [16460] Msg:[Unable to get property 'substr' of undefined or null reference - TypeError: Unable to get property 'substr' of undefined or null reference 00000005 1.00342023 [16460] at ShellCallbacks.isFileSupported (Unknown script code:1:2387) 00000006 1.00342023 [16460] at ShellCallbacks.prototype.getSamplingRate (Unknown script code:1:2998) 00000007 1.00342023 [16460] at Anonymous function (Unknown script code:1:925) 00000008 1.00342023 [16460] at Array.prototype.reduce (native code) 00000009 1.00342023 [16460] at CallbacksBase.prototype.getSamplingRates (Unknown script code:1:900) 00000010 1.00342023 [16460] at CallbacksBase.prototype.filterEvents (Unknown script code:1:2036) 00000011 1.00342023 [16460] at filterEvents (Unknown script code:1:43) 00000012 1.00342023 [16460] at _dispatch (Unknown script code:13:21)] 00000013 1.12678611 [14924] shell\\explorer\\taskband2\\taskband2.cpp(4148)\\Explorer.EXE!00007FF79CCE77CA: (caller: 00007FFEDBB88443) ReturnHr(54) tid(375c) 80004005 Unbekannter Fehler

Not clear what do you mean with IIS User. It’s a standalone XOJO EXE File running in Admin Priviledges (or System as Service). It works perfectly on Win7 or Win 2008R2 Server but not on Win2016.

I still see mostly lines that are related to the management console. Right at the beginning, the management console complains about an illegal function. Is substr something in your application? It could be where the app fails and exits.

 Msg:[Unable to get property 'substr' of undefined or null reference - TypeError: Unable to get property 'substr' of undefined or null reference

There is also this error line (unknown error?)

shell\\explorer\\taskband2\\taskband2.cpp(4148)\\Explorer.EXE!00007FF79CCE77CA: (caller: 00007FFEDBB88443) ReturnHr(54) tid(375c) 80004005 Unbekannter Fehler 

which could indicate that your application cannot even start.

Now, dumb question: is your application compiled for Windows 64 bits? (I mean, the executable that you are currently testing - I know that you tried both at some point.)

If you have a full access to the server, I would attempt this - the goal is to remove entries in dbgview that have to do with the management console:

  • set the service to manual start, so that it does not start automatically. reboot.
  • log on the server with an admin account
  • remove the run as admin on the web app executable properties
  • using task management, confirm that your webapp is not already running. close task management.
  • start dbgview
  • launch the executable from windows explorer: does it run? if it fails, what do we see in dbgview?

Alrighty the Standalone 64 Bit WebApp is now up and running.

The reason is quite stupid. The WebApp http-port was already used by some unknown HP Server Management Stuff even the customer’s admin didn’t know about. So the WebApp couldn’t start and no further information could be found in any log oder sc query.

My previous attempts with another port were made from commandline --port switch only. When hardcoded, it works.

Thank you all for your help.