Xojo reports....

I have a report inside of my program that I was tyring to get to do a summary of ‘sales’ and a summary of ‘tax’. So, I added a group section. Now I only get a blank report no matter what field I tell it to group upon.

How do I delete the group sections?? I have tried to make a new report to copy the fields over, but the editor in the new report keeps flashing to the first one that is in the application??? (I am running the linux version of xojo, latest releast 2013 3.3)

Ok, if no one knows how to delete the group sections, could someone at least tell me how to use them? I have tried to group by just about every field in my report, and always the sections is BLANK!! I would really like to have a populated report, grouped and summarized if possible…

Left click the group section far left in report window to select the group to be deleted, then hit the DEL-key on keyboard.

Ok, I right click on the group section, it turns blue, I hit delete and the whole report disappears.

I would be ok to leave the groups in… I was trying to get a total for sales and taxes, but I can’t get the grouped body section to show ANY fields… it prints blank… how do you use the group function? I have put every field I can think of in the group by entry in the inspector for the group section and there is no change.

you group by a column in your data set

Left click instead of right click on group header is the key to success. With a right click still the whole report (in the Navigator list) is marked, with a left click only the group header is selected - and will be deleted.

Groups with sums you get when you drag a new Reportfield from Library into the GroupFooter (or -Header) and adjust the Datafield and to the Field from Database you want the SummaryFunc and SummaryType in the Inspector window. Most important is the Field has to fit into the GroupFooter part, if its Height or Width is too big, it’s cut off.

Hope this’ll help.


I have tried every field, column, etc in the group by box for the group header, the report is still blank…

Thomas, I have right clicked, left clicked, deleted with delete key, with the popup menu item, still, the whole report is deleted, not just the group section…

Check this Screenshot - I used the original Xojo Printing & Reporting demo program List Of Products and added a new grouping (1 + 2) - dragged a new Reportfield (Field4) onto new group footer (3) and changed the item properties (4). That was all I needed - worked in Linux and Windows for me. Same with left clicking the group header or footer (2) and hitting the DEL-key on keyboard (no right clicking or dragging or stuff).

Oops - something went wrong with image link. Here it is:Screenshot

I understand… and have done that the exact same way, but it stil only deletes the whole report, and I usually get blank reports or blank body sections when I try to do add a group field to the group sections.

I am running a 64 bit linux… could that be the difference???

Hm, could be, with your 64Bit Linux.

Tho I tried it here with Ubuntu 12.04 LTS 64Bit and Linux Mint Olivia Cinnamon 64Bit, both working in Virtualbox 4.3.0 r89960 with my changes to the Xojo-Project mentioned above. Same with Ubuntu 13.10 64Bit on my main computer.

Problem on main computer was it didn’t work in IDE in debug mode, but worked fine compiled (Have to figure out why tho … s.b.). Setting up Xojo in 64Bit Linux is … kinda … not that easy (warning! incorrect technical term #1 :wink: ). Check this out: 64Bit issues There still are many unknown features (warning! incorrect technical term #2 :wink: ) in Xojo with newer versions of Linux 64Bit (speed IDE, strange mouse/keyboard behavior, warnings, hangups, missing libs/links, htmlviewer, …). Tried to run the new Beta4 for that, but IDE didnt start and bothered me with some new warnings i had no time yet to look up (warning! incorrect technical term #3 :wink: ).

Will have another trial run this weekend.

Well, I tried to load the program into a windows based version of Xojo, and I get the same results. I can only delete the whole report, not just the group section.

Found the solution - left click the GroupFooter1 (not the GroupHeader1) and hit the DEL-key on keyboard. I always clicked the footer as i had the group sum in there, when i select the group header instead, whole report is deleted (not only the group section).

Edit: This ‘feature’ is gone with new Beta5, deleting groupings only works with both header and footer there.

Hmmm… tried on my windows machine, still deleted only the whole report… I would like to keep the group section if it would work… but no matter what I put in the groupby field in the inspector, the section is ALWAYS blank

However, it worked in Linux… so now my report has no group section! Yeah… I can finally get some data printed in the body.

Thanks Thomas!

Ok, getting there… now it will print the first row from the database in the body, but not the following rows… working with reports in XOJO is quite aggravating…