Xojo randomly changes image sizes

Hey guys,

when I add an image to my Xojo project (drag and drop on the image 1x field), Xojo seemingly randomly changes the size.

Example: If I download this icon as a 32x32 png file: http://www.flaticon.com/free-icon/move-arrows_108763#term=move&page=1&position=22 , the size in Finder and preview is 32x32. When I add it to Xojo as an Image, it becomes 7x7.

Is that intended behavior? If so, why?


Just downloaded a 16x16 PNG and added it to a project and it comes in as 16x16 just fine

weird. I tried downloading an SVG and converted it to 32x32 / 64x64 / 96x96 PNGs.

They came out alright.

Check the resolution of the images, the differing resolutions have a weird effect on how some apps handle them.

If you’re original was an SVG I’m not surprised it did not work right
SVG’s are poorly supported on all platforms at the OS level which Xojo relies on

In fact I’m surprised the IDE didn’t outright reject the SVG file

Thanks for the answers.

The original was a PNG downloaded from Flaticon, not an SVG. I used the SVG to create my own PNG which then worked. But probably, Tim was right as there must have been something with the resolution of the flatiron PNG file.

Be very mindful about not only pixels, but about resolution as well. That counts for HiDPI.