Xojo Provided Examples - Testing and Documentation

Greetings Everyone:

For me, this is Xojo day one. I am web-based developer with Python as my goto language currently. However, years ago I obtained my Visual Basic MCSD while working on client-side business applications. Now, I would like a rapid tool for quick demos for my business clients across multiple devices. I am hoping this fits the bill. I thought it would be nice to checkout the examples that come with the Pro package. Where did I start? Trying the examples - of course!

LOL! Nothing works. Breaks everywhere. Class call errors. I have tried to open several example apps - none that I have tried runs. EXCEPT, the Controls applications such as Bevel Buttons. They work great! Anything that incorporates a little more coding, seems to fail.

So, I went and researched the boards. A man named Paul - apparently not the Walrus - created a forum spot called Examples in 2014. It’s blank. (I’m sure Paul has real work to do, and getting Combat to work is probably not anywhere near his list - let alone on it.

However, it has become painfully clear that no one has done an extensive test of all the examples with documentation that I can find. Again, the first example I went for was a game - of course - the application is Combat under the Games folder in the Example Projects directory (folder). The only fighting going on with this application is me fighting the breaks.

Example Projects > Games > Combat (Yes, I copied the files and am running them off the Desktop)

Here’s the Combat application errors (all are breaks):

CombatWindow.GameTimer.Run Declaration

GameTimer on CombatWindow implements the event “Run,” but its superclass Time has already implemented the event. Sub Run()

CombatWindows.StartButton.Pressed Declaration

Startbutton on CombatWindow implements the event “Pressed,” but its superclass PushButton has already implemented the event.
Sub Pressed()

Now granted I am using the “King of the Buggy OS’,” Microsoft Windows 10; however, I was hoping for some better documentation. (I know Paul’s on it - Just kidding Paul.)

Yes, I have plugged in the power, and have rebooted my system. (“Have you tried turning it off and then back on?” - The IT Crowd TV Show)

For us grizzled folks, this is just another day, but it would be fun to know what I am doing wrong, if anyone else is having this issue. If no one is, then I am grateful that you are not me.

The one thing that I have noticed is everyone here seems very nice, and that is the best part of Xojo so far for me. Thanks for your help or at least reading this far. Take care and I look forward to someone’s reply. Or at the least, I hope you have better things to do than get Combat working in the Example Projects folder. :slight_smile: - Don

Welcome @Don Montgomery. In version 2019R3.1 the example works without any issues on my Windows 10 machine, so I’m not sure why you’d be seeing these issues. Perhaps uninstall & reinstall Xojo? Do you have any 3rd party plugins installed?

I sure appreciate you’ve got a sense of humor about this problem! Many would be more critical.

The truth of the matter is the Xojo language is evolving and making sure the examples are all updated to work with the latest builds is probably not top priority (though there’s a strong argument that it should be) for a small company. I’d guess that 99% of those errors are very minor and easily fixed, if you know what the errors mean and how to fix them. :wink:

Probably your best avenue would be to pick two or three examples you’d like to get running (ones most appropriate for your needs) and see if those of us on the forums here can tell you how to fix them. Most of us experienced developers probably haven’t looked at the examples too recently so we wouldn’t notice if they’re broken.

Hi Don, what version of Xojo are you running? I suspect the Examples that you are trying and the IDE that you are using are not in sync. Recently, there has been a change in the Xojo API. You’ll see it simply referred to as API 2.0 on the forum.

The latest version of Xojo is 2019r3.1, which can be downloaded from https://xojo.com/download/. The examples included in that package should all work with that version of Xojo.

@Don Montgomery
i expect that u installed the current version of xojo.
make some notes that people can reproduce this issues or record your desktop screen.
and be aware that online docu can be newer than this one came with the setup.
the code snippet fragments in docu are not really helpful.

web apps get update to api 2 soon! it will be very different to api 1.

there was some event renaming and then undone after release of api2 for desktop.

Uninstall 2019r2.1, delete the installer and any examples you copied to your desktop from the 2019r2.1 folder then reinstall 2019r3.1 and try all this again it should fly through without any issues.

Sorry for your trouble with this, Don.

As others have said the examples seem to be working fine in our testing so perhaps try uninstalling whatever version you have and re-installing 2019r3.1 as other suggested. It sounds like you may have the examples out of sync with the Xojo version.

I did a test, downloaded Xojo 2019r3.1 and Combat worked without issues using Windows 10.

I think the forum has some issues, it says that Don joined 9 years ago, first post this one and he is a Xojo Pro and pre-release tester. Weird.

I do not know, but this behavior is reported with many people.

Me included, you excluded. In my case, there is a 8 years gap between the registered and the first post (and this is certainly the case: I recall lurked a day or two and left).

[quote=478604:@Emile Schwarz]I do not know, but this behavior is reported with many people.

Me included, you excluded. In my case, there is a 8 years gap between the registered and the first post (and this is certainly the case: I recall lurked a day or two and left).[/quote]
The weird part is that OP is marked as pre-release tester and with Xojo Pro license. People can create an account many years ago and don’t visit the forum or post anything, I understand that.


I really appreciate everyone’s replies. I must say, what a nice group of folks.

Duh, I should have said what version I am using --> Xojo release 2.1.

Windows 10 strikes again! As a ‘former and recovering’ Microsoft fanboy, I must say that I was not disappointed with the expected outcome of using a Microsoft OS. Windows 10 to me is terrible for many reasons too long to list here. (As in … needing to write a PowerShell script to recover my restore, maximize and close buttons. Really, Microsoft??)

All of you gave excellent advice and I appreciate the feedback very much. Gavin S, Markus R, Julian S, and Paul L, you are correct. The Windows API calls were not working correctly in the language, because I installed the Xojo release 3.1 first, and then uninstalled it. I realized I had purchased a licensed copy in 2019. Being a ‘thrify’ kind of guy, I reinstalled an older version (2.1) over the newest version. I should have created a Windows 10 restore point, installed the Xojo 3.1, and then did a restore to the pre-install registry configuration state. (I was too excited to try it out. Some things never change with our friends at Microsoft.)

Last night, I created a VM and installed the latest version of XOJO 3.1 on a fresh copy of Windows 10 and it worked fine. So, I assume it left some infrastructure from the core development of Xojo 3.1 and that is why it could not instantiate the classes in the event calls from an older version.

Ubuntu Linux - Perfection! As always, Ubuntu 18.04 with Gnome was no problem. Installed in less than a minute, and my little blue tank was blasting the poor red tank to pieces. Linux wins again! (In my early days, Novell was red and IBM was blue…but I digress.) I ran a web-based example and it created a daemon to process the text get and post strings, and the client talked to the server seamlessly. Great job!

Not to bore all you further, but Alberto D and Emily S pointed out my 9 year old status. There is no problem with the XOJO forum. From 1997 to 2007 I was a Lead Instructor at CompUSA in Atlanta, GA. I was the Microsoft Certified Trainer for MCSE and MCSD (VB) classes. The company went bankrupt and I took the top clients and started my own training company. In 2010, I was at the fork in the road, distributive computing or go “cloud.” In 2010, when I heard that the RealBasic team had developed a web-based solution, I downloaded RealBasic for myself having not worked (or beta tested) the product in three (3) years. It was pretty crude at the time and I saw the writing on the wall for client-side focused efforts.

Obviously, I was going to go Microsoft’s cloud as a direction, but Microsoft abandoned the Microsoft Certified Trainer program, and seemed to abandon its MCT community entirely. I went back to school and got a Masters Certificate in Network Security and Assurance from Southern Polytechnic University (Now Kennesaw State). I graduated Magnum Cum Laud - Yeah! Seeing that open-source was blossoming I shifted from Microsoft to Unix systems and never looked back. I focused on network infrastructure automation (Python automation) and training/custom courseware (digital) design for our clients IT infrastructure and service teams. I now have been a technical writer/consultant 12 years.

Finally, (bless your patience) a year ago I decided see how the client-side was doing and downloaded Xojo. The year 2019 was very busy for me and Xojo sat in the ‘someday’ pile. Yesterday, I took the ‘plastic wrap’ off of Xojo, and that is why I said it was ‘day-one.’ I really have not looked at the product since 2010. I know that was too much information, but no one ever tells the whole story on these kind of boards. I thought it would be a refreshing change and I just wanted to clarify things.

Again, thanks again to everyone for your replies. I’ll mainly use Xojo as a front-end web client to my Python automation scripts. My first tests are working great! In ten years, this product has come a long way. Great job Xojo team! Peace and health to you all. :slight_smile: -Don

Ummm… I have stumbled, jumped, skipped, slipped, and maybe even sashayed, Emily S… but never lurked - never I tell you - Never! heehee :wink: Hope this clears things up. :slight_smile: