Xojo Plugin weirdness on macOS Sierra

I’m having issues with Xojo on macOS Sierra not seeing the Plugins folder. The issue appears to be the same one as described at <https://xojo.com/issue/44586> but I am running Xojo 2016r3. When I go to the Loaded Plugins pane in the About Xojo window, nothing is loaded, even though I have MBS and dtPlugins in there.

I trashed the install, rebooted for good measure, downloaded everything from scratch but still no success. But then again, I’m sure many of you are running Sierra and I’m not seeing lots of complaints. I can’t think what would be unique to my recent, and clean install of Sierra, though. Any ideas?

Also, is it just me or does Spotlight not see Feedback.app? Every other app is fine, including Xojo.app. (I use Spotlight as an app launcher.)

any messages in console.app about this?

Hi guys, yes, there are a couple of messages:

default 17:26:23.558248 +0100 lsd SecTranslocateCreateSecureDirectoryForURL: created /private/var/folders/7c/48s14z014rn_y_vb63vcsf0m0000gn/T/AppTranslocation/97B453E8-C13A-4BFD-B152-A707CB06A397/d/Xojo.app
default 17:26:24.050882 +0100 Xojo <compose failure [shared UUID]>

The first one is just GateKeeper moving the app but what’s the second one about?

The app translocation may be that the plugins folder is not found.

Could you try removing the extended attribute from the app?

Done and that solved it, thanks.

Using spctl, I checked that both the dmg and Xojo.app were properly codesigned and they are. So who knows what the issue is.

Also, for what it’s worth I have no problem launching feedback from spotlight in Sierra ( I use it as an app launcher as you do. )

App Translocation was moving the application, so it couldn’t find any plugins. Perhpas Xojo can check for that in the future and at least alert the user?

Not clear what you’d want it warning about ?
That it has been translocated ?
Or that there are no plugins loaded (which isn’t necessarily abnormal) ?

[quote=291123:@Norman Palardy]Not clear what you’d want it warning about ?
That it has been translocated ?
Or that there are no plugins loaded (which isn’t necessarily abnormal) ?[/quote]
Sorry for not being clear Norman, it wasn’t a dig at Xojo. In the future perhaps you can warn users when Xojo is being translocated as it’s not clear to the user as to why their plugins are not working any more.

Maybe when it opens, if it can’t find a Plugins folder, it then checks to see if it’s being translocated.

It would also help if Apple would alert the user, “The application Xojo has been put into Quarantine, some features may not work while the application is in Quarantine, please download a new copy of the application from the vendors website.” I know there’s easier solutions, but downloading it a better way of ensuring that it hasn’t been compromised.

I’ve actually submitted a Radar on that requesting the same thing.


Christian and Gavin,
You told about “translocation” and “removing extended attribute of the app”, but I don’t understand what’s that.
Of course, I have the same issue with the plugins folder. I tried to remove the “.app” suffix and lauched Xojo through the terminal, it worked! But I’m expecting a more efficient workaround or solution.
Thanks for detailing what is “extended attribute” and how to remove it.

In the feedback report Christian outlined how to use Terminal to remove the Quarantine flag.

xattr -d com.apple.quarantine [Path to Xojo.app]

Great! It works!

For what is worth, Xojo 2017r1.1 worked well until it crashed. After that, it didn’t no longer load plugins.
Thanks to xattr, it now works like a charm!

Thanks to Tim and other contributors of this thread.

I would highly recommend to Xojo to add it to the IDE for an auto fix.
So if it sees it’s translocated, it could show a dialog and remove the attributes itself.