Xojo on Ubuntu - Run

I’ve seen a lot of posts and followed the requirements to enable Run and still can’t get the latest Xojo to work on latest Ubuntu. Does anyone have a step-by-step guide to get Xojo to Run on Ubuntu?

Out of curiosity do you get a tool tip when you lave your mouse over the disabled Run button?

This is how one can find out why Run is disabled in iOS projects, but I’m not certain if it offers anything for other project types.

Update: oh you mean getting the IDE to launch

The Run button next to the Build button.
image

Ah! If that’s the case, I restore my question :slight_smile:

Do you get a tool tip when you leave your mouse over the disabled Run button?

Yes, it’s states Run your project using the debugger

PS. I followed the requirements for Linux Ubuntu here https://docs.xojo.com/Resources:System_Requirements

Sorry, that’s all I’ve got for finding out why the button is disabled. I’m of the opinion that the user experience for that needs to be improved dramatically.

2 Likes

What’s odd to me is that the Build button isn’t disabled. What happens if you click that?

The build button works and compiles to a Linux a Solution that I can then move to my raspberry pi.

Ah, OK. In the navigator on the left, make sure “This Computer” is checked under Build Settings.

image

OK, thanks Anthony I will try that and see if it works. I thought I did try that but maybe I just didn’t notice if the run button was then enabled.

I had to select to change the build target from the default ARM 32-Bit to x86 64-bit with This Computer selected. Now I can run/debug but now my code abends on
MoviePlayer1.Movie = Movie.Open(fiMovie) :face_with_raised_eyebrow:

Thank for your help All.

Glad you got it sorted out!

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.