Xojo on RHEL 7

Just wondering if anyone else here is running enterprise Xojo web apps on RHEL 7 - or CentOS 7?
If so I would love to share tips with you if you have any you want to share.

Sorry, I didn’t reply because I am only using CentOS 6. Works fine, but you need to install the libraries.

Hey David - thanks for writing back. Yes I have also used Centos6 - there is no issue running apps - Red Hat is great with Xojo… I am more talking about DevOps tips. There are some important differences between RHEL 6 and 7 like firewalld instead of IPtables and systemd instead of upstart… Are you using upstart to launch/watchdog your apps?

Let me know if you have found any interesting stories to tell.
Here are some things you might be interested in - let me know if you do:

  • 1 click deployment using rsync, systemd (or upstart for 6) and Xojo build automation
  • Web application management using systemd (or upstart for 6)
  • Custom xojo logging using syslog
  • Remote debugging over the internet using SSH
  • Load balancing with haproxy
  • SSL termination with haproxy
  • Scalable Xojo webapp architecture with HAXXX (Haproxy, Apache, Xojo instances)

Hi @John Joyce and @David Cox,

I’ve just been told that I need to move my fairly complex web app from Ubuntu 14.04 to RHEL 7. This scares me as I know how fragile Xojo web is on 64-bit Linux, but I’m going to have to go ahead with it.

I’m moderately competent in Ubuntu, but haven’t used Red Hat for about a decade or more. Is there a collected repository of tips and tricks for Red Hat 7 somewhere?


Here are some of my CentOS/RHEL notes I’ve accumulated:

CentOS/RHEL/Fedora 64-bit
For all CentOS/RHEL systems you must run:
sudo yum install ia32-libs
sudo yum install ia32-libs-multiarch

Try launching your app — if it runs then great, otherwise newer versions of CentOS/RHEL may require additional steps as well:
sudo yum install glib2.i686 libgcc.i686 libstdc++.i686

If your application still complains that a certain library is missing, then you can find out which packages install that file by:
sudo yum provides missinglibrarypathorname

or for Mint Linux
ldd /path/to/your/file

Choose one of the packages and run:
sudo yum install packagenamewithlibrary

Run your application and repeat this process until all the required libraries have been installed. It took me about five cycles with CentOS 64-bit.

Notes on YUM
yum install postgresql.x86_64 ‘installs a package, but please install Postgres via GUI else it is installed twice!
yum -y install postgresql.x86_64 ‘no need to accept with a yes command
yum remove postgresql.x86_64 ‘uninstalls
yum update postgresql.x86_64 ‘upgrades an older version
yum search firefox ‘find the package name
yum info samba-common.i686 ‘get info about the package
yum list | less ‘lists all packages
yum list installed | less ‘lists all the packages installed on your system
yum list libicu* ‘allows you to find the variant with the i386 extension and install that
yum provides /etc/sysconfig/nfs ‘tells you which package provides the missing library or file
yum grouplist ‘lists all package groups to make installation easier
yum groupinstall ‘DNS Name Server’ ‘installs a group package
yum groupupdate ‘Graphical Internet’ ‘upgrades a whole group package
yum groupremove ‘DNS Name Server’ ‘uninstalls a whole group package
yum repolist ‘view all my currently enabled yum repositories
yum repositories disabled ‘view all my currently disabled yum repositories
yum repolist all ‘view all my current yum repositories, both enabled and disabled
yum --enablerepo=fedora-source install vim-X11.x86_64 ‘install a package from a disabled repository
yum shell ‘allows you to run multiple yum commands
yum reinstall httpd.i386 ‘install package using local repositories where available
yum reinstall package-name ‘reinstall a package — useful if you accidentally delete a file
yum –downloadonly install postgresql ‘downloads a package but doesn’t install it

Wow, super helpful! I’ll start with your suggestions and see how it goes.


and if you use the Text - Type

you have to install libicu.i686 (for 32bit) libs and libicu for x64 apps

here what i had to do on my CentOS 7 Server:

yum install glibc.i686 libgcc.i686 libstdc++.i686 glib2.i686 libicu.i686 libicu libsoup libsoup.i686

now Xojo-App & Xojo-Webapps run in 32Bit and 64Bit

Thanks Ren. I’ll be setting this up later today and will use David’s and your suggestions.


forget about ia32-libs

yum list ia32*

shows there a no packages with that name on centos 7 (Standart Core install)

So, if there are no ia32 libs for centos 7 (nee RHEL), does that mean that Xojo can’t work on this distro?

@David Cox: your first step fails:

sudo yum install ia32-libs

Gives the message:

No package ia32-libs available.

Any suggestions? This is related to what René reported. It’s extremely unlikely I’ll be able to convince the IT and Security groups to bring up an old version of RHEL (they’re on 7.x).

Sounds like I’m dead in the water. Back to PHP I go.

Build your app as 64-bit with 2015r3 and you won’t need ia32-libs.

@Paul Lefebvre: I recall now why I didn’t do that originally: I get an Unhandled Exception right after launch when I run a 64-bit Linux version of the web app.

I’ll dig a bit into this and see what I can find.

Our Web Apps compile with 2015 Release 3 to 64-bit executables and run Stand Alone on Ubuntu 15.10 Desktop AMD64 and Ubuntu 14.04.3 Server AMD64 without issue.

Hopefully you’ll find the Unhanded Exception is a coding problem and not a framework problem that we have yet to discover.

Hi all,

Well, silly me. I compiled, as @Paul Lefebvre suggested, for 64 bit using Xojo 2015r3, and everything worked. Well, almost everything. I have an issue with an MBS plugin that’s apparently not 64-bit friendly.

This is on a fresh RHEL 7.1 server, spun up as an AWS t2.medium instance.

I did not need to change anything on the server; no yum-install, nothing. It worked out of the box.

Thanks, Xojo!

[quote=226942:@Charles Weger]Hi all,

Well, silly me. I compiled, as @Paul Lefebvre suggested, for 64 bit using Xojo 2015r3, and everything worked. Well, almost everything. I have an issue with an MBS plugin that’s apparently not 64-bit friendly.[/quote]

You’ll need the updated MBS plugins which have 64 bit portions

Yes I know. Tried to get them using Christian’s Dropbox, but I get a 404 error. Do you have an updated URL for his 64-bit plugins?

Ask Christian for that
I dont

There is a link to pre-release 64-bit plugins on his blog post: