Xojo on Linux

Artcle on http://cully.biz/2014/04/07/xojo-on-linux-part-1-of-2/

“Imagine that your new version of Mac OS X started taking 5 seconds when you right+click on a control.”

It wouldn’t - because there is something called quality control.

Linux is a perpetual beta, and to tout the fact that you have to change distros to get around bugs an advantage „because you can’t do that on other OSes" is really stretching my imagination.

Xojo can be painful on certain distro’s :frowning:

Apple has often made decisions that were at least temporarily painful to the Xojo developers. Requiring the removal of Quicktime, Sandboxing, Cocoa. Yes, Apple has quality control but that doesn’t mean that their checks of quality are in concordance with Xojo as a development tool.

I definitely count the ability of moving to another distro (Linux Mint, SolydK, and others) a benefit when that distro performs much better than another (Ubuntu). Choice is a good thing.

Not at all. Linux is a very stable ambient, but full of choices (KDE, XFCE, Gnome, etc). It’s just a question of choosing a good distro for your hardware (usually one of the top 10 on distrowatch, I personally focus just on the top 5 and keep listening the crowd about the news), make good choices; and as developer, follow its changes, as you do in OS X. US Army, US Navy and NASA uses Linux.

Choice can be paralyzing - http://www.ted.com/talks/barry_schwartz_on_the_paradox_of_choice
Too many distros - too many choices
I think this is what’s helped make a handful of distros more popular than others for desktops although Linux is still a VERY tiny minority of all deployed desktops.
Servers are a totally different can of worms.

That’s a good article, and the video is especially nice. But in all fairness to both the Ubuntu and Gnome teams, neither is knowingly shipping desktop environments that take 3 to 5 seconds to just drop down a menu. I’ve seen some apps perform better than others, but the slowest menu rendering I’ve seen in either Unity or Gnome Shell is a fraction of a second, and most are instantaneous.

This isn’t a matter of quality control, certainly not with hundreds of developers, tens of thousands of testers, and millions of users. It’s simply a matter of accounting for what appears to be an edge case no one on the dev or testing teams for those DEs has encountered before.

Does this happen with all apps, or just those made with Xojo?

If the issue is seen across all apps, it may be that the hardware is just too old to run the latest DEs, and switching to something like XCFE would do wonders (I run that in Lubuntu on an old Atom 230-powered nettop, and even on that slow CPU it performs like a champ).

If the issue appears specific to Xojo, it’s such an outlier that I’ll bet it would be a relatively simple fix.

  • Ubuntu 14.04 does not seem to like Xojo. Errors.
  • Ubuntu 12.10 32 bits is unstable on my AMD PC. It goes bezerk about audio DRM although I am not using any audio file, and it explodes.
  • Cinnamon Mint 32 bits is splendid, stable and fast, but when I start Xojo it asks for what kind of project, then goes pumpkin

Now which one of the supported distributions should I try first ? Which one works best with Xojo IDE ?

  • OpenSUSE,
  • Fedora (Gnome, KDE, LXDE or Xfce Spin ? ? ?) confusing choices again…
  • CentOS

I like Mandriva and saw that the Mageia project is the Open Source branch of it, but it is not supported.

Is there a brilliant distribution I should absolutely try that is not listed here ?

I was spoiled too long with Mac OS X and Windows : install it, install Xojo, and it runs. Is there today the equivalent in Linux ?

Try Luna :slight_smile:


[quote=80845:@Lee Page]Try Luna :slight_smile:


Looks impressive. And it is 11th in Distrowatch. Does it run the Xojo IDE fine ?

Installed Fedora. And downloaded the Red Hat Xojo installer.

Fedora refuses to install. Error message :

Failed to install File Two packages provide the same file. This is usually due from mixing packages from different software sources.

I have double clicked on the only file I downloaded : xojo2014r11.rpm

When I experience such discouraging circumstances, it makes me extremely dubious about the possibility to do any kind of business with software for Linux. I cannot imagine my Mac or Windows customers going through such meanders :frowning:

The manuals says the following, and should be true. Maybe needs review.


Xojo current supported Linux distributions:


The following x86-based Linux distributions:
    Ubuntu 10.04 or later
    Debian 6.0 or later
    OpenSUSE 11.3 or later
    Fedora 13 Desktop or later
    CentOS 6.0 or later 
At least 2 GB RAM

Compiled applications run on these versions:

Ubuntu 10.04 or later
Debian 6.0 or later
OpenSUSE 11.3 or later
Fedora 13 Desktop or later
CentOS 6.0 or later

The Fedora problem seems to be related to the rpm package. I was able to install the files themselves.Still, it is not simple…

Good news : I installed Linux Mint 16 “petra” and I must say it is much faster and easier to use than Fedora. It installed the deb package in a breeze, and the IDE is fast and responsive. Think am going to stay with it as a replacement to unstable Ubuntu.

Working on different Linux systems here since years. I experienced almost (s.b.) no problems installing and using Xojo with following 32bit flavours of Linux:

  • Ubuntu (Unity) 10.04+
  • Xubuntu (XFCE) 12.04+
  • Kubuntu (KDE) 10.04+
  • Linux Mint Cinnamon Olivia+

When trying the 64Bit versions there were many problems even with all the posted workarounds (ia32libs etc.). Security/access rights issues, IDE crashes, HTMLViewer didnt work as expected, IDE speed is (was) crappy with some window managers, xojo feedback program refuses duty, help/docs can’t be accessed via IDE (tho online XOJO docs work).

Havent done much with Xojo in ElementaryOS/Luna, but for programmers coming from MacOS it’s the easiest way of feeling comfort with (similar GUI). Based on the 12.04 LTS version of Ubuntu it sure has the same problem with 64Bit version.

Best results I got with Xojo was it running on 32Bit Linux Mint XFCE (Olivia and Petra later). Fastest GUI. No IDE crashes at all. Only minor problems with help/docs and feedback system. So atm I use Xojo for prototyping purpose and smaller projects only (less than 500 lines of code). But I can’t await the 64Bit changes announced for next year (2015). I then will transcode many of our older linux programs / scripts and give those a better UI.

[quote=80845:@Lee Page]Try Luna :slight_smile:

I downloaded both the 32 and 64 bits version. But on my AMD64 based PC, all I see when booting on the DVD is the small keyboard and guy at the bottom of the screen, then a black screen with a prompt on the top left, the DVD spins for a while, and nothing happens :frowning:

Flying blind here, but probably you need to change some kind of setting on your BIOS: Enable Legacy Boot.
But I do prefer distros backed by companies/groups with better support.

Try this:

when you land on the grub loading screen and before selecting “try elementary OS without installing” you need to press F6 and choose “nomodeset”.

Hit escape and then chose “try elementary OS without installing”

If you install, on first boot you will have to do the same thing until your graphics card driver ) is installed and at that point it should boot without needing to set “nomodeset”.

I only use Debian Linux but have been using Elementry on the my childrens computer it does look nice…

Did not think about that. Will try and see if it changes anything.

I appreciate your advice, but the DVD never gets to Grub. The UI simply never shows.

Finally, I elected to install Linux Mint 16 and am using it right now. It is less flashy than ElementaryOS, but the UI is decent, responsive enough to make Xojo as fast as under Windows, and the compatibility with Ubuntu is a plus.

Thank you.

While this icon is shown you’re able to hit any key to have access to the start menu (bottom line F1 help … F6 options). Choose your language aso. to continue. And first check your virtual machine settings as Lee Page mentioned above. Virtualization modes and graphics settings as you want - or just let the virtualbox let it do for you by default for your guest system (ubuntu 32bit). Or just find yourself a Youtube vid with step-by-step howto.

Thomas - I appreciate you trying to help. I did get access to the start menu and was able to go through options. But the result stays the same.

You see, I am afraid this very kind of case illustrate how a good idea with a sloppy execution will never have a chance on the market. I am sure the guys who develop ElementaryOS are good. The idea to have a user interface close to Mac OS X is good too. The addition of a software store as well. But since my Apple IIe in 1982, I had never seen a system disk that does not boot. And I have tested hundred of them. Guess there is always a first time for everything.

I wonder what would happen if I told my customers to go look for some youtube video for assistance about software that does not work. Demands for refunds would flow. Maybe that’s why they stuff is free.

Either it works right away, or forget it. The Luna disks now rest peacefully in the waste basket. And I don’t need a haphazard Mac OS like interface : I got Mavericks 10.9.3 on my iMac to enjoy. For Linux, Mint works right away, and works for me. Thank you.

Could not quite let it rest. Searching through the Internet, I found that ElementaryOS does not work with NVidia display cards. One needs to select nomodeset in the boot options and finally the screen shows graphics. Not at the proper resolution, off course. All other Linux distributions I tried boot without fuss, though. Maybe the guys at ElementaryOS could get a hint. That is, if they care about user feedback. They don’t offer any way to send them mail…