Xojo not opening

my application is not opening . throwing a message “This application has encountered a fatal problem and must be shut down.”

My car wont start…

If your app runs properly in debug mode but not when deployed, you need to be thinking ‘whats different’?
There may be files it cannot find.
Locations in which it cannot write.
DLLs which are missing.

Avoid writing in the same folder as the app is deployed to: you wont have permission, and if someone runs your app from a CD, it cant write anyway.
Avoid using hard coded paths to files, or paths relative to the application: when deployed they may be in a different place.

Add an unhandled exception handler to your app.
Add a logging system so that it can write to a log before it dies about where it had reached and what it was trying to do.

Other than that ‘my app crashes’ doesnt tell your or us about what the problem might be.

i am talking about xojo . When I double click on xojo icon it will load its frameworks and after that it will throw that error message “This application has encountered a fatal problem and must be shut down.”

Do an uninstall/re-install and you should be fine.

tried many times , tried different versions too … still i’m getting the same error .

Thanks for clarifying. You may wish to change the name of the post to ‘Xojo not opening’

WIndows version?
Patch level?
Graphics card?
Available RAM?
Disc space?
Running from a CD?

Windows version: Windows 10
Patch level : Xojo 2017r2
Graphics card : Intel integrate Graphics
Available RAM :4 GB
Disc space : 1 TB HDD , C drive around 30 GB free
Running from a CD : no

Before it was working fine . I don’t know suddenly what happened to it .

no external plugins . I reinstalled many times . Not able to rectify the issue . No error codes too .

Can you run Scandisk or something similar on your machine?
Maybe permissions for a temporary folder are corrupted, or the folder itself is missing.

Xojo is loading around 95% and in the Examining plugins stage its showing that error . I clicked report now , again it will show the same thing .

Maybe try running Xojo from a different user account to see if something got corrupted in the account you are using now.

The Microsoft DebugView utility can also be helpful with unexplained crashes.

Getting a fresh download from http://www.xojo.com/download and installing again can’t hurt, either.

00000036 52.00204468 [6752] avcore
psm\localprovider\baseprovider\lib\baseprovider.cpp(604)\PSMDesktopProvider.dll!00007FFE465C2140: (caller: 00007FFE465C26E5) ReturnHr(777) tid(73c) 80070490 Element not found.
00000037 52.05787277 [6752] shell\explorer\taskband2\taskband2.cpp(4148)\Explorer.EXE!00007FF70E9477CA: (caller: 00007FFE66E67DE3) ReturnHr(1360) tid(254c) 80004005 Unspecified error
00000038 53.12301254 [6752] avcore
psm\localprovider\baseprovider\lib\baseprovider.cpp(604)\PSMDesktopProvider.dll!00007FFE465C2140: (caller: 00007FFE465C26E5) ReturnHr(778) tid(73c) 80070490 Element not found.
00000039 53.13545990 [6752] onecore\base\appmodel\resourcepolicy\gameconfigstore\client\gameconfigstoreclient.cpp(104)\resourcepolicyclient.dll!00007FFE63A5976C: (caller: 00007FFE4BE9DDE7) LogHr(156) tid(69c) 80070490 Element not found.
00000040 58.99916458 [6752] shell\explorer\taskband2\taskband2.cpp(4148)\Explorer.EXE!00007FF70E9477CA: (caller: 00007FFE66E67DE3) ReturnHr(1361) tid(254c) 80004005 Unspecified error
00000041 59.50284195 [6752] avcore
psm\localprovider\baseprovider\lib\baseprovider.cpp(604)\PSMDesktopProvider.dll!00007FFE465C2140: (caller: 00007FFE465C26E5) ReturnHr(779) tid(73c) 80070490 Element not found.

please help me to solve this issue …

Did you try what Paul suggested above, particularly with a different user account? What happened when you did?

I would make sure you have downloaded a fresh copy from our website. It could be that the installer has been corrupted in some way. Also, make sure your anti-virus/anti-malware software isn’t incorrectly seeing Xojo’s Installer as a threat and preventing all of the parts from installing properly.

Beyond that, have you tried installing Xojo on another machine?