Xojo Not Compatible with Xcode 13.2.1?

Hey all,

I upgraded my Xcode today to 13.2.1. Is Xojo not compatible with it? I can’t compile/debug/etc. for iOS any longer…

Xojo 2021r3.

1 Like

Could you elaborate? What errors/issues are you having?

All the compile/run buttons are not there. I tried to do an Analyze and got an error that Xojo could not find acttool. I tried typing actool in terminal and got notice that my developer directory was pointing to command line tools.

Yesterday I had installed Xcode Command Line tools and from reading some threads on Github, it looks like I need to set the Xcode developer directory back to the app:

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

Instead of the Command LIne tools location. I deleted Xtools as I had an error as well when updating it yesterday and I’m still waiting for the download/install to complete.

Works fine here with macOS 12.1 and Xcode 13.2.1 running on M1 Pro

Right. Any time there’s an Xcode update, you need to launch Xcode and make sure the tools are pointing to the right location or run that command in the terminal.

3 Likes

It’s all good now. Sorry for the false alarm!

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.