Xojo iOS on-device debugging appears broken (again) with iOS 17

I’m getting an error when running the debug version of my app on my iPhone 14 Pro after upgrading to iOS 17:

The operation couldn’t be completed. {someSortOfId}: no identity found

There were no issues with on-device debugging prior to iOS 17. I can still debug in the iOS Simulator but some features that I use are only available on the device.

Just posting here in case someone has found a workaround. If not, then here’s the ticket: https://tracker.xojo.com/xojoinc/xojo/-/issues/74073

Update: Actually I can’t build at all with Xcode 15.

As usual, im also having an issue with running the app on the device (iOS 17). Building does work here with the latest xcode, running just doesn’t.
Xojo should be on top of this, as always we have these kind of issues we know would happen in advance so there should be a fix asap.

Make sure you have the Xcode 15 tools selected in the Locations pane of the Xcode preferences. That’s usually what the problem is.

Also, this was working with the Xcode 15 RC last week, so it may not be Xojo’s fault.

Just checked it here and it’s working just fine for me.

Interesting. So I’m finding that this doesn’t work with all of my devices. My iPhone 8 is working (it’s running iOS 16.7) but my iPad 9 (iPadOS 17) is not. I’ve got several other devices here to try.

I hoped xojo was on top of such issues. Now there is no way to develop for ios again. This is really frustrating.

Ok guys, we are on it… meanwhile (kind of workaround) For us it is possible to run the apps on the Simulators from Xojo (using macOS Sonoma latest release + Xcode latest release), and also Build them from Xojo so it is possible to copy the app to the device (iOS 17.0) through Xcode.

Great. Does it (or could it) include other variations of the issue? (I’m getting a “Compilation of project failed.” dialog instead of the OP’s error, also since I updated to iOS 17)

Sadly it doesn’t work for me (but that’s not new).

I confirm it works. I’d prefer not to compile each time, however, because I’m trying to adjust things.

So if anyone’s having trouble with iOS 16, I was able to get my iPhone 8 running 16.7 into a non-working state. The fix was to remove the Wildcard profile that Xcode creates for you from your Mac. Once I did that, I was able to debug on that device again.

Yeah, that’s exactly the same error we are digging in. The app is copied to the device (iOS 17) but it doesn’t connect to the debugger (kind of interrupted in the process, before the app installation is already completed)

Make sure you have the right simulators & SDK installed on Xcode 15 (delete the previous ones from the beta releases)

1 Like

Exactly what I’m seeing. Thank you for confirming.

I can run in the simulators without issue. But I can’t build my app for on-device debugging, or a standalone debug build or an App Store build. I didn’t use any of the Xcode, macOS or iOS betas. This is just current release software.

Hi @JasonTait

I replied to you in the Issue you created on our Tracker system. It gives you more clues about the things you can look at… and hopefully solve your signing problem.

About the issue related with the generic “Run On Device” when the target device has iOS 17.0 installed, we are working on it.


I think the issue is with XCode 15 and not necessarily iOS 17. I created a new app with a button and tried to deploy it to a device running iOS 16.7 and got the same results; cannot connect to the debugger so app closes… Using Xojo 2023 R2 and Xcode 15.

Hopefully this will warrant a point release on r2 so we don’t have to wait for r3.

1 Like

I have iphone with ios 17 and xcode 14, i can’t deploy with 14 nor 15. Yes i’ve updated the location in xcode settings.
Even the tools are back.
Still can’t run on device.

I did some testing tonight and here are the results.

Xcode 14.3.1 with command lines tools 14.3 installed, and Xcode 15.0 with command line tools 15.0. Got the same results with both Xcode 14 and Xcode 15.

iPhone 14 iOS 17 - App copied to iPhone but didn’t launch and then instantly received an error message in Xojo.

" Compilation of “test” failed.

An error occurred when attempting to launch the application. Please make sure the device stays awake and unlocked and check the Minimum iOS Version."

iPhone 11 iOS 16.7 - App copied to iPhone and launched to a white screen. Eventually times out and an error message on iPhone. No error message in Xojo and had to manually stop debugging.

"Cannot connect to the debugger

Since we could not locate the target IDE to start a debug session, this application will now exit."

iPhone 7 iOS 13.2 - App copied to iPhone without any issues and debugger launches as it should.

1 Like

Thanks @Thomas_Dalke that’s about the same issue as i have.

We develop for the latest targets always (this case iOS 17) since the end users use those latest versions. In xojo there is no way to do on device debugging, i think builds are broken too but i’m not sure. First of all we need to be able to debug (pointed to xojo) the latest targets, advice to use fall backs is not possible in this case.

Uh… you mean “right now, because of this bug” right? Because starting in 2022r1, you certainly could…

Ha well ofcourse i mean “right now” since apple pushed updates e.g. to iOS 17 just recently. The on-device is a feature yes i know it’s there a while.

1 Like

You’d be surprised how many people don’t know about it.