Xojo IDE won't save

Hi all,

I was trying to put together a sample project to upload to a thread about another issue, when I encountered a problem where my new project won’t save.

I’m on Xojo 2016 R1.1 on Windows 10, and I had my old project open, created a new project (naturally opens in a new IDE window) and copied and pasted the window into the new project.

Now, none of the “Save” functions work. The screen flickers but Xojo seems to be unable to display any sort of Save dialog. It’s like the IDE’s .SaveAsDialog method is failing. I also can’t Open anything either.

I have created this video to demonstrate: https://www.youtube.com/watch?v=V49Y7eQtB7M

Any ideas? I’m now afraid to work on ANYTHING for fear that I won’t be able to save.

Is your license key showing up as active/current?

Indeed it is: http://i.imgur.com/dVRS0X2.png

I have also reinstalled Xojo and this issue remains.

Where are you trying to save ?

Anywhere. I can’t even get the save dialog to open.

That is pretty weird. Never seen something like that. There is the whole deleting the cache and appdata stuff, which is sort of last resort. Does the same thing happens with a new project, like New Desktop project, and Save As (without pasting any data or anything)?

Correct. A brand new, empty project also exhibits the same behavior.

If I open an existing project, I can save and it will overwrite it, but I can not “Save As.”

It’s like the IDE can’t display any type of Save dialog from the Windows GetSaveFileName API.

Have you restarted Windows ?

Just throwing stuff to see what sticks: did you use the SaveAs function on 2016 R1.1 before? Can you try 2015r4.1? Could it be a “corrupt” download (if this is the first time you try SaveAs under 2016r1.1)?

Good thought - Will give that a try when I get back home to the machine. I’m currently accessing it at work via TeamViewer but if I restart now TeamViewer won’t restart with it.

I have 2015r2.3 installed and it works as expected. 2016r1.1 worked fine up until today (but it’s the first time I’ve used it on this machine in a while).

Since the save dialog is a system feature and not a Xojo program, chances are it will solve the issue.

Unfortunately a reboot has not solved this issue. Xojo 2016 R1.1 Windows still won’t save.

Interestingly, when I use Xojo 2015r3 to save, the dialog displays, but Xojo crashes after choosing a filename.

I would strongly suspect something to be wrong with Windows itself. The save as dialog is a function of the system, pretty much like the print dialog. You may yet have issues with other programs coming if for some reason Windows is corrupted.

Did you erase/cleared the XOJO cache? Can you run it as an Admin or from another account? Do you have an AV which may be thinking XOJO is not what it is (maybe disable it while you try to troubleshoot this). I have to assume that SaveAs from any other application is ok.

Cleared the xojo cache and the problem remains. No AV and I’m running on an admin account (only account on the system) with UAC disabled.

I use this system daily for very heavy tasks: video editing, music production, 3d renders, etc and no other applications have any problems, so while I totally understand that it’s likely a problem with Xojo interacting with Windows, I’m not able to reproduce any similar problems with other programs.

In fact, I can write a xojo program that displays the save dialog and saves text to the resulting file, then run it in the debugger! I just can’t save the program I wrote. :X

Thank you all for your help with this, I’ll keep trying things as I think of them. Thankfully I still have my Mac to do development on.

My Xojo license doesn’t come with tech support but I wonder if this may be something they may be able to help me with as it’s a problem with the application itself and not questions about the language, etc.

Stupid question: what is the save option you used ?
License # may allow you to save… or not in the format you want.

Default (and Free) is: xojo_binary_project

[quote]none of the “Save” functions work[/quote]: cannot be the license restriction. Sorry.

@Christian Wheel
So that SaveAs window looked “different” to me. Turns out that since 2015r3 Xojo updated the SaveAs as follows: [quote]Modernized Open/Save/Select dialogs (i.e. using Vista+ style dialogs instead of XP style).[/quote]
It is one of those why change if it works, but there it is nonetheless. Can you go a bit further back than 2015r3 and see if the problem goes away?

I wonder where the dialog is trying to open as a default directory.
Maybe the ‘current folder’ is an invalid path… perhaps an external drive that is no longer connected, or a CD drive that is read only.
If you examine the properties of the Xojo icon, what folder is the startup folder?

Update! This is somehow related to the MBS Plugins. When I remove them, this problem goes away and I can save normally! @Christian Schmitz, any ideas?

I think this may be related to the Max DLL issue. I have ONLY the MBS plugins installed (latest beta from the dropbox), no other plugs. But when I remove a number of them (it doesn’t seem to matter which specific plugins I remove, as long as I remove enough), my ability to save returns.