Xojo IDE will not load in Linux Manjaro

Hi all, I’ve been using Linux Manjaro for over a year now with no issues. I switched to it because I was able to print directly to a printer which you can’t do in Mint. Recently, the Xojo IDE stopped working. My compiled applications still work but the IDE won’t load.

IDE freezes here:
Reading Preferences Freeze

Manjaro Info:

Any suggestions on how to fix this or debug it?

Make sure your OS still uses the needed libs, which can be found on System requirements for current release — Xojo documentation (starting at the lower 3rd of the Page).

BTW: What happens in the Terminal, if you start the IDE from there?

Not sure how to start from terminal.

Open a Terminal and drag the App into it. :slight_smile:

 /home/james/Applications/xojo2022r32/xojo2022r3.2/Xojo  :heavy_check_mark:
libocci.so.10.1: cannot open shared object file: No such file or directory

I had the same issue a few weeks ago, on Ubuntu 22.04 . Xojo IDE had been running fine on the machine a week before but then refused to load with the same error. As I only needed to open a project to look how I’d done something I used another machine running both an older version of Linux and Xojo which hadn’t been switched on or updated in while, which worked.
Unfortunately I can’t be much help on resolving but I have seen the issue recently. Clearing out preferences and reinstalling made no difference.

Sounds like Oracle is messing again with the lib-Path.
Maybe this can help: libclntsh.so.10.1: cannot open shared object file: No such file or director — oracle-tech

Thanks, but this is way over my head. It’s weird, worked fine on Thursday but then suddenly not on Friday.

If you have installed an Oracle Instant Client, maybe it’s good enough to just reinstall it as described here: Instant Client for Linux x86-64 (64-bit)

If you’re not using the oracle database plugin, remove it from the plugins folder next to the Xojo app.

2 Likes

Turns out after much trial and error the issue is related to a conflict with Evolution. I did a complete reinstall of Manjaro and gradually added apps and narrowed it down to Evolution email client. Using Thunderbird now and all is well.

2 Likes