Xojo IDE doesn't redraw after monitor sleep

This is a new problem since updating to 2022R4.1.

After my monitors turn off (10 minutes of inactivity), when I return to the PC, the Xojo IDE doesn’t redraw and appears like this. I have to close the application and open it again.

Edit to clarify: It is only the monitors turning off. The system is not going to sleep.

Running Win10 with an RTX 4090. Latest nvidia drivers.

Anyone else experiencing this, or know any workarounds? It’s really annoying!

That’s pretty peculiar the monitor power status has nothing to do with wether the video memory needs to be redrawn. So long as the system remembers that there is a monitor attached it should keep the video memory alive and show it when the monitor gets power again. There should be nothing for the software to do.

If the monitor is somehow signalling the system that the monitor is “removed” it could kill the video buffer. Windows on that display should then be moved to another still attached monitor, or at the very least signal a paint event when it is restored.

It would be worth checking what ever the monitor control panel is called these days, ie the settings for the display. What settings are there for the display, perhaps one of them is in need of changing.

It seems like a problem with the monitor / windows configuration, rather than anything to do with Xojo. Do other applications on the display also do the same thing?

Thanks for the reply. Xojo is the only application affected, and I was previously using 2022R2 and it also is not affected.

It would be worth opening an issue:


If you can provide simple steps as to how to reproduce the issue, including the monitor / OS / driver versions.

I’m having a similar issue on windows. I’ve got a desktop app running 24/7 on a computer that I remote desktop into. Each time I remote in, the app is running but needs to be redrawn. I just close and restart. This has only been happening recently.

1 Like

It is as if there is a screen wake event that is being ignored by Xojo, or it is somehow missing paint events from windows in some way.

I guess you tried already, but doesn’t it work to just resize (or maximize/restore) the window?

1 Like

I also have a problem like this with one of my apps on a server that is running 24/7 where I access via remote desktop.

Not every time, but 2-3 times a week, the app window is white with no control visible. I forced a Refresh every time I click on the window and also tried changing the window size but nothing happened, the only way to display the window again is to quit and relaunch the app.
When the problem appears, the app seems to work normally, performs routine tasks in the background and consumes 2-5% CPU. I don’t have a precise date, but seems that the problem appeared with a version of Xojo 2022Rx
Of course this problem only occurs at one customer and it is impossible to reproduce it so far in the office…

The Build is in x86 64-bit

I see this a few times a week. Windows 11 on Surface Laptop Studio. I connect/disconnect from an external monitor connected to a USB-C hub.

Could this be the result of a memory leak or something similar?

Same issue here.

I use X2022R4.1 on Win10 via Microsoft RDP. The “Xojo Server” is a headless machine (No Monitor, no Keyboard, …) and if i do not access it for a while (can’t exactly say how long…) it shows the same screen in the RDP Client as @Matthew_Dinmore1.

I have the feeling it happens since 2022 versions and never before.

in my case this also happens when I launch the application from debug and then, having tested the app, I go back to the ide which remains without project objects and with only the menus

1 Like

This could be related to the following bug:


Just FYI… this has not been resolved for me in 2023R1 beta 59261. I added a note to the issue.

It has not been resolved? The ticket is closed and marked as fixed :frowning:
(Alberto mentioned on the ticket how to handle this)

#71377 - Wrong alignment of controls after switching on/off the second (main) monitor (IDE and built applications) (closed)

1 Like

New issue created:

Controls are not refreshed on Windows Desktop app when logging into a remote desktop session (#71928) · Issues · Xojo Inc / Xojo · GitLab