Xojo.Data.ParseJSON extremely slow on Linux

It seems to me, that using Xojo to create a webservice on a Linux machine, which makes use of JSON, is a complete no-go, because it is unacceptably slow.
If you want to get some database data via a linux webservice to your iPad or desktop app, then you probably need to look for other options than a Xojo webapp.

Kem Tekinay reported the issue, which he noticed on Windows, last year and he created a testapp which can be downloaded from feedback:

I did run Kem’s test as a standalone webapp, in macOS Sierra, on Windows 10 Creator and on a Ubuntu Linux vps.
What seems to run well on macOS is extremely slow on Windows and far off on Linux:

The app creates a large JSON text, then times how long it takes to parse it:
macOS Sierra 10.12.5: 0.75 seconds
Windows 10 Creator : 16.2 seconds
Ubuntu Linux 14.04 : 48.8 seconds

My webapp can be downloaded from here:


Windows 10:

Ubuntu Linux

If you have some spare feedback points, you could give some weight to the issue here:

Well this is odd. Using a VM running Mint 18, I cannot reproduce your results. The parsing takes 0.65 seconds, give or take, on both Mac and Linux. Trying Windows 10 now…

And I’m getting the same results in Windows. What’s going on here? Was this fixed silently in 2017r1.1? Oliver, are you using the latest version?

I’m at a loss for what I’m seeing. My original test project (desktop) shows the same slowness on Windows and Linux, but your project, Oliver, is speedy on all platforms.

With the last public version: I built it with 2017r1.1

Hmm, what results do you get from here (Ubuntu Linux vps):

47 seconds connecting from the Mac.

Oh, of course, it’s an ID-10-T error. I was running in debugging mode so naturally the web pages on Windows/Linux were going to reflect the faster time of the Mac.

Ignore me, I’ll go get some coffee.

I have a webapp running on that server, which makes use of json (but sending only small junks of information around), which is much more responsive:

@Oliver Osswald: here are the times I got after building and running your test app:

Mac: 0.704 seconds
Linux (RHEL 7.3): 19.928 seconds
Windows 10 (desktop): 5.884 seconds

I agree, the Linux and Windows times are unacceptable.
Compiled with Xojo 2017r1.1 on MacOS 10.11.6

Oliver, have you tried my JSONItem_MTC replacement for JSONItem? I think you’ll find the performance acceptable until the new framework text handling is fixed.

Good hint! I use it in a desktop app, but I have not tried with the test app here. I’ll do that asap.