Xojo App with MBS keeps asking for Screen Recording Permission

I tried using Xojo and MBS to make an app I would setup as a Launch Agent that would take a screen shot of the user’s current screen when they submitted a ticket to our help desk. The problem is that every time the app launches, either by me killing the process and relaunching, or the user rebooting, it asks for the screen recording permission even though it’s clearly already selected in the security preference pane for that feature. I’ve tried different users with different OS versions. Reset the permission using the tccutil command line option. But every time the app winds up getting launched is asks for screen recording permission. Any ideas?

Is your app signed and notarized?

1 Like

ahhhh… ok… I’ve built signed apps for IOS using Xcode for the App Store… first time building an app in Xojo for internal use… I didn’t think of that… thanks… looks like I have some reading to do!!!

1 Like

Tip: Use AppWrapper from Ohanaware. It can save you time and hairs.

3 Likes

Since I’ve seen weird combinations with MacOS always asking the same things on installed applications and notarised/not-notarised apps (and never truly understood), I’d be interested in your findings.
After you notarised your app, did the problem vanish?

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.