Xojo and High Sierra

I need to build an app for macOS High Sierra. Does anybody know which is the newest Xojo IDE I can use to build for High Sierra?
I mean the application executable must run in High Sierra, the IDE will be building in macOS Big Sur. I tried with 2020 and failed.

Probably 2019r3.2

Thanks I will try that.

Do you know if 32bit or 64bit?

2022r2 sets a LSMinimumSystemVersion of 10.10.0

Xojo 2020r1 IDE requirements:


  • At least 2GB of RAM
  • macOS Catalina 10.15.x
  • macOS Mojave 10.14.x
  • macOS High Sierra 10.13.x
  • macOS Sierra 10.12.x

Desktop Apps System Requirements:


  • macOS Catalina 10.15.x
  • macOS Mojave 10.14.x
  • macOS High Sierra 10.13.x
  • macOS Sierra 10.12.x
  • OS X El Capitan 10.11.x
  • OS X Yosemite 10.10.5

What did you try and how it failed?

Found this link for Xojo2022r1 requirements:

For Xojo2020r1:

In 2019 we had lots of changes. API2 transition, and 32 bit becoming abandoned. I don’t remember, but 2019r1.1 and 2019r3.2 were 2 landmarks. I think r1.1 was the latest API1 complete, and r3.2 the latest 32bit carbon/cocoa capable. Not sure. That’s why I said r3.2.

The executable did not run, and a window popped up saying that the developer must optimize for High Sierra, the good news is I am sure it was not 2020r1, I always download the latest of each year when I try this things.
I will try 2020r1 64bit then. I do not want to go too old so I modify the less code as possible.

I don’t know what to tell you, both Xojo2020r1 and Xojo2022r1 say they can build apps for High Sierra.

Maybe you build with Xojo2022r3.1? That version doesn’t support High Sierra.

A little bit of google goes a long way

1 Like

2022r3 runs fine on High Sierra. Apps made with the version also run fine on High Sierra. Except for the html viewer which has been crashy in the last 2 years. Which is why I also tell my users that my app is supported for macOS Mojave and higher.

my main dev computer is an oldy macbook pro 17" from 2011
still running high sierra (it can’t go higher)
I use the last xojo version 2022r31 like Beatrix, and it works fine
my customer (private ones I don’t publish on the app store) runs also until monterey

Thank you Beatrix,

I guess it is what Tim said, OP build a 32-bit app and tried to run it on an updated High Sierra. I think is not possible to build 32-bit Mac apps anymore with 2022r3.

OP didn’t say anything about 32bit.

no this is not possible anymore
Capture d’écran 2022-10-29 à 15.33.27

No, but all I had to do was google the phrases the error gave them to come across multiple articles about it.

I used these specifically

The original post didn’t include nearly enough information, so my original reply was short and fact based. :man_shrugging:

Mentioned 32bit here:

And here mentioned that will try 64bit:

That’s why I guess 32bit was used and according to what Tim posted, that will show the exact message OP mentioned using an updated High Sierra version (.4 I think)

BEFORE High Sierra, 32 bit was the usual preference of many Xojo users due to the stability of the compiler/frameworks. With High Sierra (10.13), the 64 bit migration started to be “enforced” with messages. Mojave (10.14) was the last macOS carrying 32 bit frameworks. Catalina+ (10.15+) are 64 bit only and can’t even try to run anything. So, the OP seems really trying to compile some legacy 32 bit code.