Xojo 2022r2 and macOS High Sierra 10.13

According to release notes, the minimum system requirement for Xojo 2022r2 IDE is macOS Mojave 10.14.
However, did anyone try if it works on macOS High Sierra 10.13? Thanks.

Ups. I didn’t read that. So far Xojo 2022r2 works fine on High Sierra. In fact it’s much better than on Ventura where Xojo crashes like mad.

2022r2 is working nicely here on high sierra.
the next beta is also working but it seems it won’t last long if you saw this mojave minimum…
shame I will have to change my trusty macbookpro, … or don’t update.

Before 10.14 the new MacOS 64bit framework wasn’t “complete”. So it’s a risk trying to, because depending on what you do, you can step on some OS/Xojo landmine.

It is good news. Thank you all for the information.

High Sierra is the last sane version of macOS. I’ll update when I have to.


You are 100% right.

As I still need to support a few machines on High Sierra for now (they can’t go beyond that), I wish I knew what was likely to break if I used 2022R2 with api 1.

I could not stay on 2019R1.1 because of a JSON bug in how it handles doubles (well I could have coded a work around but I did not have the time). If I can’t stay on 2019R1.1 it would nice to be able get the IDE bug fixes even if I’m using API 1.


@Geoff_Perlman , I also would really like this next release where it seems a lot of bugs have been cleared, to be available for high sierra still… let’s cross fingers.

I don’t know about the IDE, but despite the new claimed Mojave minimum for apps built with 2022r2, I just tried a new build of one of my projects on my Yosemite VM and it works perfectly.

We’re not really on the right channel to be talking about the beta, but I’m not frowning. :slight_smile:

Perhaps for now it’s a “your mileage will vary” thing. This is an apt expression because the situation reminds me of a conversation with my father in the late '80s. I was telling him about how I was dramatically beating my new car’s “sticker” on fuel economy. He replied, “Don’t tell the dealer–they’ll fix it.” :slight_smile:

The system requirements are for support purposes. They are not a declaration of what versions of OSs apps will/will not run on.

But that’s literally what System Requirements are for.


That’s how it started but for many products, while it’s called requirements that’s not precisely what it means. I was just looking at the FileMaker system requirements page for example. What they do is list each version of FileMaker and then list the minimum version for the listed operating systems but then note that later versions may also work.

We could change it to Supported Operating System Versions for the Current Release which would be more accurate and then put in a search hint of “system requirements” but I’m not sure that’s necessary.

We, as developers, need to know what operating systems our products will and will not run on. Posting anything but actual requirements is an absolute failure on your part.

Edit: You’re comparing “may work on future versions” to your “may work on older versions” which is not acceptable. It’s okay to not know the future, but you should absolutely have a grip on how far back your build results can run.


You must document what compilers (Xojo versions) are compatible with what range of OSs. For example, the dark mode was introduced on Mojave, so I don’t expect the current support for dark mode working on High Sierra for example.

Curious as to your opinion on this, i.e. why you call it the last sane version. I’ve been holding out with Mojave on my main MacBook Pro. I’ve been very happy with Mojave and really dread the day I have to upgrade my main work/personal machine. I do have other machines running later versions for testing.

I do understand the reasoning here. But it would be useful to have a separate list of absolute minimum requirements. Maybe “unsupported but should run”? It’s rare, but it is possible to run into a situation where a client has to support older machines, but a newer version of Xojo has some feature or bug fix which really helps out. I’ve been there before, trying to discover if I could trust builds on an older OS.

I just want accountability and clarity. I have several projects where the end client is using older systems, so this information must be accurate.

I’ve filed a ticket for clarity on the deprecations and removals page because that’s all I’m looking for here.

Waving of hands and saying “may just so happen to work on 10.13” will not cut it. I need accountability from the people who build the toolchain. A boolean, not a variant!

Please just update the deprecations and removals to list what IDE version can build for what platform. We’re missing information from 10.10 onwards.


For stuff like this, it’s not hard to nest code, dark mode in this case, within methods that first test for Mojave minimum.

That’s just one example. What else can cause a hideous crash? Better check the docs and if it says “For Mojave and above” you just follow the docs.

1 Like