Xojo 2022.3.2 crashing on macOS 13.3.1 (a)

Is anyone else who’s installed the latest macOS security update able to launch Xojo 2022.3.2?

For me, it’s hitting an OutOfBoundsException. Could this be because the macOS version number is now “13.3.1 (a)”?

FWIW, Xojo 2023.1.1 is fine but I need 2022.3.2 for one of my projects.

Yes.

As far as I remember, Xojo incorrectly tried to parse the OS Version String (!) in their implementation of System.Version in some previous Xojo versions. And since the Xojo IDE is using that itself, it’ll fail with an (unhandled) OutOfBounds Exception once a “Fast Security Response” is installed (whenever there is a macOS Version string that has an appended (a) or similar).

Xojo 2018r4 is fine, too :wink:

Since this Xojo Version has the flawed implementation of System.Version, all you can do is uninstall the Fast Security Response Update. And don’t use System.Version in your applications built with that Xojo Version…!

Even though you obviously shouldn’t do that (do that at your own risk by intentionally not having the latest security updates)…:

How to remove a Rapid Security Response update in macOS

  1. Open System Settings from the Apple menu
  2. Select GeneralAbout
  3. Hit the ⓘ (Info) button next to the macOS version
  4. Hit the Remove button under Latest Security Response
2 Likes

Thanks, @Jürg_Otter : really helpful to know that it’s possible to revert the security update. I’ll try to hold off doing that for a bit in the hope that Apple release an update with a “normal” version string.

Ouch! :face_with_hand_over_mouth: :grimacing:

1 Like

See https://tracker.xojo.com/xojoinc/xojo/-/issues/71254 .

1 Like

Yikes!

Please file and post a report on tracker, and I’ll do my best to elevate that.

It looks like it was fixed in 2022r4.1 Release Notes — Xojo documentation as per Beatrix’s post but Tom needs to use an older version. Xojo posted that they don’t fix older versions so I’m not sure a ticket will help unless their position has changed recently?

Worst:
I am unsure a simple patch in 2022r4.1 is even possible (due to the code signing, etc. process…) like it was so many years ago.

I’ve had two reports today of users who upgraded to 13.3.1 (a) and now have out of bounds exceptions that sound very much like the version.system problem (the clue is that they can’t send me an automated email, which includes system.version.tostring, because trying to do so generates the same error in a loop until the app is forced to quit). At least one of them is using a version of my app built with Xojo 2023r1.1. I’m running 13.3.1 (a) myself and have no issues, but I wonder if under certain circumstances the bug still exists in the current release.

Darn, I missed that. You’re right, reports that apply only to older versions are not considered, afaik.

While I don’t know that there is anything we can do about this, I’m looking into it. Thanks to @Kem_Tekinay for bringing it to my attention.

2 Likes

Why is that?
e.g. why can’t you use another version like 2023r1?

Patching older Xojo 2022r3 is a huge effort for Xojo Inc. Like they’d need to get old source code for framework, patch it, build it and assemble a new dmg for the old IDE changed to use new framework.

Why do you need that specific version?

If you’re in the middle of a large project, sometimes changing the version of the software you’re using is a variable that you don’t want to endure.

Xojo itself doesn’t have this issue because they are always using the latest version or something newer.

4 Likes

It’s kind of laborious, but if you have the need then you can revert macOS to a previous version (well, reinstalling with the original version for that particular Mac); and then updating from there until before that particular security update that breaks Xojo 2022r3.2.

Doing that on an external drive/partition also should work… leaving your current main drive / macOS version untouched. In fact I have a lot of external drives around here just to start from any given macOS version supported on any of the Macs sitting here.

That said, I also know why Xojo doesn’t patch older versions of the IDE… so I don’t know what the solution is here.

Although that would fix running the IDE itself, it won’t fix the built project running on a Mac with a supplemental update.
The iOS framework uses System.VersionData in many places, the Mac framework might be doing the same.

1 Like

I’m using 2022.3.2 for my desktop app because 2023.1 started causing crashes on Windows near the end of a beta testing cycle and I haven’t had an opportunity to investigate that yet.

I can work around Xojo 2022.3.2 not working on macOS 13.3.1 (a) for a while, I’m sure Apple will release an update with a “normal” version string soon.

Yeah, Apple released macOS Ventura 13.4 Beta 4 yesterday… so… :+1:

1 Like

One warning about 13.4 beta 4. It causes Wifi connections to drop every few seconds if you have any sort of network filtering software installed. For example Little snitch. However, it also includes Sophos. It doesn’t seem to affect Ethernet connections.