Xojo 2021r3.1; Win; MBS;SQLExecuteMT; crash in a thread


I got a crash in a thread with or without using the debugger while calling SQLExecuteMT.
Unfortunately even a try-catch does not capture the error.

Any idea how to find the problem?
Is usage of debugger in a thread general not a good idea?

Thanks lot for any hint!

Do you have a crash report?

Should I find one in Xojo folder?
Program simply stops.

Can you see the crash on macOS, too?
Because there you get crash reports as text.

Otherwise something for us to reproduce?

I assume you have recent version of our plugin.

Yes, recent version of Xojo and MBS plugins.

I’ve checked all calls switched to -MT version.
I debugged thorugh source and when first SQLExecuteMT occurs, program stops.

Aim was being able to observe the progress in compiled exe though a textarea.

Workaround is a log file which is reloadable when changed.

What I forgot to mention → it’s a SQLite database which I use

Well, I just tried it and it works here.
So there must be something different for you.

Can you provide a little test project causing the crash?

Thanks a lot for checking this!

Very difficult to reproduce the error when program simply stops.
If will try to find the problem despite this and report if I can focus an error.

Maybe you access the same database connection on another thread?
Like a timer to check if connection is still alive.

Also I tried to use AddUserInterfaceUpdate.
So, as I used these thread things not a lot before, I assume an error on my site.
I will report any lights up;-)