Xojo 2021r1 on RHEL Linux crashes on open/save project

I’m a Xojo Windows user but I wanted to try developing on RHEL 7.6 Linux. The install went fine. I can code and debug without issue, but any attempt to open or save a project causes Xojo to silently crash (it just disappears - no smoke, no bang). Any clues would be appreciated.

Please run the IDE from a command-line and see if you get any error messages when it crashes.

When I start Xojo, I see OpenJDK version messages for version “1.8.0_242”, then when I open a project, all I see is “Segmentation fault”
Here’s the ldd for Xojo, FWIW:
||linux-vdso.so.1 => (0x00007ffd27905000)|
|—|—|
||XojoGUIFramework64.so => /home/andrew/xojo2021r1/./Xojo Libs/XojoGUIFramework64.so (0x00007f9b819b3000)|
||libc.so.6 => /lib64/libc.so.6 (0x00007f9b815c7000)|
||libgtk-3.so.0 => /lib64/libgtk-3.so.0 (0x00007f9b80d11000)|
||libgdk-3.so.0 => /lib64/libgdk-3.so.0 (0x00007f9b80a7b000)|
||libpangocairo-1.0.so.0 => /lib64/libpangocairo-1.0.so.0 (0x00007f9b8086d000)|
||libpango-1.0.so.0 => /lib64/libpango-1.0.so.0 (0x00007f9b80622000)|
||libatk-1.0.so.0 => /lib64/libatk-1.0.so.0 (0x00007f9b803fc000)|
||libcairo-gobject.so.2 => /lib64/libcairo-gobject.so.2 (0x00007f9b801f2000)|
||libcairo.so.2 => /lib64/libcairo.so.2 (0x00007f9b7fecb000)|
||libgdk_pixbuf-2.0.so.0 => /lib64/libgdk_pixbuf-2.0.so.0 (0x00007f9b7fca5000)|
||libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007f9b7f92e000)|
||libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007f9b7f6de000)|
||libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007f9b7f3a7000)|
||libX11.so.6 => /lib64/libX11.so.6 (0x00007f9b7f068000)|
||libm.so.6 => /lib64/libm.so.6 (0x00007f9b7ed66000)|
||librt.so.1 => /lib64/librt.so.1 (0x00007f9b7eb5e000)|
||libdl.so.2 => /lib64/libdl.so.2 (0x00007f9b7e959000)|
||libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007f9b7e757000)|
||libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9b7e53b000)|
||libunwind.so.8 => /lib64/libunwind.so.8 (0x00007f9b7e320000)|
||libunwind-x86_64.so.8 => /lib64/libunwind-x86_64.so.8 (0x00007f9b7e101000)|
||libc++.so.1 => /home/andrew/xojo2021r1/./Xojo Libs/libc++.so.1 (0x00007f9b7dd50000)|
||libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f9b7db39000)|
||/lib64/ld-linux-x86-64.so.2 (0x00007f9b84156000)|
||libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007f9b7d935000)|
||libXi.so.6 => /lib64/libXi.so.6 (0x00007f9b7d724000)|
||libXfixes.so.3 => /lib64/libXfixes.so.3 (0x00007f9b7d51e000)|
||libatk-bridge-2.0.so.0 => /lib64/libatk-bridge-2.0.so.0 (0x00007f9b7d2f3000)|
||libpangoft2-1.0.so.0 => /lib64/libpangoft2-1.0.so.0 (0x00007f9b7d0de000)|
||libfontconfig.so.1 => /lib64/libfontconfig.so.1 (0x00007f9b7ce9b000)|
||libXinerama.so.1 => /lib64/libXinerama.so.1 (0x00007f9b7cc98000)|
||libXrandr.so.2 => /lib64/libXrandr.so.2 (0x00007f9b7ca8e000)|
||libXcursor.so.1 => /lib64/libXcursor.so.1 (0x00007f9b7c882000)|
||libXcomposite.so.1 => /lib64/libXcomposite.so.1 (0x00007f9b7c67f000)|
||libXdamage.so.1 => /lib64/libXdamage.so.1 (0x00007f9b7c47c000)|
||libXext.so.6 => /lib64/libXext.so.6 (0x00007f9b7c269000)|
||libharfbuzz.so.0 => /lib64/libharfbuzz.so.0 (0x00007f9b7bfcc000)|
||libfreetype.so.6 => /lib64/libfreetype.so.6 (0x00007f9b7bd0d000)|
||libpixman-1.so.0 => /lib64/libpixman-1.so.0 (0x00007f9b7ba5f000)|
||libEGL.so.1 => /lib64/libEGL.so.1 (0x00007f9b7b83e000)|
||libpng15.so.15 => /lib64/libpng15.so.15 (0x00007f9b7b612000)|
||libxcb-shm.so.0 => /lib64/libxcb-shm.so.0 (0x00007f9b7b40e000)|
||libxcb-render.so.0 => /lib64/libxcb-render.so.0 (0x00007f9b7b200000)|
||libxcb.so.1 => /lib64/libxcb.so.1 (0x00007f9b7afd8000)|
||libXrender.so.1 => /lib64/libXrender.so.1 (0x00007f9b7adcc000)|
||libz.so.1 => /lib64/libz.so.1 (0x00007f9b7abb6000)|
||libGL.so.1 => /lib64/libGL.so.1 (0x00007f9b7a91f000)|
||libffi.so.6 => /lib64/libffi.so.6 (0x00007f9b7a716000)|
||libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f9b7a4ef000)|
||libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f9b7a2d4000)|
||libatspi.so.0 => /lib64/libatspi.so.0 (0x00007f9b7a0ad000)|
||libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007f9b79e5c000)|
||libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f9b79c32000)|
||libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f9b79a2d000)|
||libgraphite2.so.3 => /lib64/libgraphite2.so.3 (0x00007f9b79810000)|
||libbz2.so.1 => /lib64/libbz2.so.1 (0x00007f9b79600000)|
||libX11-xcb.so.1 => /lib64/libX11-xcb.so.1 (0x00007f9b793fd000)|
||libxcb-dri2.so.0 => /lib64/libxcb-dri2.so.0 (0x00007f9b791f8000)|
||libxcb-xfixes.so.0 => /lib64/libxcb-xfixes.so.0 (0x00007f9b78ff0000)|
||libxcb-shape.so.0 => /lib64/libxcb-shape.so.0 (0x00007f9b78deb000)|
||libgbm.so.1 => /lib64/libgbm.so.1 (0x00007f9b78bdf000)|
||libdrm.so.2 => /lib64/libdrm.so.2 (0x00007f9b789d2000)|
||libXau.so.6 => /lib64/libXau.so.6 (0x00007f9b787cd000)|
||libglapi.so.0 => /lib64/libglapi.so.0 (0x00007f9b7859f000)|
||libxcb-glx.so.0 => /lib64/libxcb-glx.so.0 (0x00007f9b78384000)|
||libxcb-dri3.so.0 => /lib64/libxcb-dri3.so.0 (0x00007f9b7817f000)|
||libxcb-present.so.0 => /lib64/libxcb-present.so.0 (0x00007f9b77f7c000)|
||libxcb-randr.so.0 => /lib64/libxcb-randr.so.0 (0x00007f9b77d6c000)|
||libxcb-sync.so.1 => /lib64/libxcb-sync.so.1 (0x00007f9b77b64000)|
||libxshmfence.so.1 => /lib64/libxshmfence.so.1 (0x00007f9b77962000)|
||libXxf86vm.so.1 => /lib64/libXxf86vm.so.1 (0x00007f9b7775c000)|
||libpcre.so.1 => /lib64/libpcre.so.1 (0x00007f9b774f9000)|
||libsystemd.so.0 => /lib64/libsystemd.so.0 (0x00007f9b772c8000)|
||libcap.so.2 => /lib64/libcap.so.2 (0x00007f9b770c2000)|
||liblzma.so.5 => /lib64/liblzma.so.5 (0x00007f9b76e9d000)|
||liblz4.so.1 => /lib64/liblz4.so.1 (0x00007f9b76c88000)|
||libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x00007f9b76a06000)|
||libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x00007f9b76801000)|
||libdw.so.1 => /lib64/libdw.so.1 (0x00007f9b765ba000)|
||libattr.so.1 => /lib64/libattr.so.1 (0x00007f9b763b4000)|
||libelf.so.1 => /lib64/libelf.so.1 (0x00007f9b7619e000)|

Well we don’t use OpenJDK or Java anything in Xojo so that’s not coming from us.

I’m curious looking at that list though… do you have any plugins installed? If so, could you try removing them and seeing if you can open/save your project?

I renamed the Plugins directory. I don’t knowingly use any plugins. Restarted Xojo, tried to save a project, same issue - Segmentation fault. I also still get the Java version message when I run Xojo.

I’ve created a case for this and we’re looking at it

Was there any resolution to this issue? I am having the same issue with RHEL 7.9 with 2021.r2 and 2021r2.1 strace sees a generic SIGSEGV. ldd -v shows all lib64 libraries are present The Linux IDE works on RHEL 8.4 with libunwind 1.4.0 from CentOS, Manjaro 21.07 (Arch), Clear Linux 34820 (Intel), and OpenSuse 15.3. So, I can keep working, but I would like to build against RHEL 7, the local majority user base. In the strace, there are a number of futexes, appearing to stall in futex_wait(), right before the crash or the IDE is killed. This looks similar to an old RHEL 7.1 kernel bug fixed ~2015.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.