Xojo 2020r1 Crash create web project win10

Good morning,

After installing the new version 2020r1, as soon as I try to create a new web project xojo closes down. Any ideas? I uninstalled the old version thinking they would conflict.

https://www.dropbox.com/s/y42uy4gmae6idix/2020r1%20crash.mkv?dl=0

Does anyone know where xojo’s data is stored? Because even after I emptied the folder C:\Users\user\AppData\ I noticed that a lot of xojo’s data still detects them as Company Name,Application Identifier,license etc… Registry?

Hi,

I just tried that and the IDE did not quit. I started 2020r1 IDE, selected to create a new Web app, Xojo worked for a few seconds and the IDE appeared.

Can you provide details that may help understand the issue ? What version of Windows are you running on ? On my side I use Windows 10 Pro 2004 with latest patches.

You may have many versions of Xojo installed without any problems.

Hi,
Thank you for your answer. Surely it is a problem of my computer because a few days ago I installed it on another one and it was working properly. I am using Windows 10 Home 2004 build 19041.508. I opened a feedback in which I added also the dmp of the crash. I uninstalled the old versions because I didn’t know what to do anymore. I deleted all the data in the windows registry, data and folders in \AppData\ but it didn’t work …

As a troubleshooting step, it might be worth creating a new Windows user account and trying Xojo from there.

Thanks for the suggestion but I just tried it and the problem persists.

I needed to reinstall Windows 10 Pro on my dev computer because of weird things happening with Xojo. After a fresh install, all is fine now. Since you have same kind of issues, that means the OS, at least Windows, can affect Xojo operations in some ways. I wonder what’s going on. This computer was running Windows 7 and was upgraded to Windows 10.

Reading the dmp I think it is more of a problem due to the new compilation of xojo. If instead the problem is only my computer then I will format it. Thanks

I confirm that the crash also remains on version 2020r2… We’ve just renewed the license and I’m a bit fed up that the various feedback is never taken in consiederation. I tried a clean installation of windows 10 and the problem persists. I think the bug is related to some instruction of xojo that goes wrong with my hardware, but I think it’s absurd to change computer for such a fault. If this feedback is ignored like the one related to the HttpSecureSocket class crash I don’t see many alternatives. What is the purpose of buying the license? To buy bug fixes of other users or Features that are not needed?

  1. Does the older version of xojo still run ok?
  2. Does a normal desktop project run ok?

If 2 = yes then:

Run File>New>Examples>Advanced>XojoScript>XojoScript.xojo_binary_proect
When running, clear “Print “Hello, World!”” from top box
Copy & paste in the following into the top box:

Sub Baz (d as Double)
Print "OK"
End Sub
Baz (0.0)

Click Run on the window, does the window close or do you see a dialog window like this?

image

Yes version 2019r3 works well. Desktop version 2020r2 also works but as soon as I try to do what you told me, the window closes.

Thanks, then your cpu doesn’t support some of the instructions that xojoscript is trying to use due to a bug in xojoscript.

If William can confirm this then you won’t be able to use this version on your CPU until Xojo releases their fix for feedback://showreport?report_id=62678

@William_Yu Does 2020r1 & 2020r2 use xojoscript on web project startup now or does the bug also reach into the framework?

Thanks Julian, I understood that it was a problem with my hardware but I would never have been able to detect the problem. I hope it will be solved soon.

The bug would only be caused with the use of XojoScript and floating point calculations, which our IDE would be affected by if there are any IDE scripts in the project. We also take advantage of XojoScript with Web Projects for CSS parsing so that may be what Attilio is running into. Creating any other project types (like Desktop, iOS, etc.) should be fine.

1 Like

If I can do a few more tests to help you identify the problem, please ask.
Thank you

Solved with version 2020r2.1, thanks.

1 Like