Xojo 2016 R1 on Arch-Linux (Manjaro)


the new Xojo 2016 won’t start on my Manjaro (Arch-Linux) Main System.

(I Maintain the Xojo AUR-Package .)

Where would i find the Xojo Dumps (on Linux) for creating a Feedback Case?

So i could get help so it runs again.

PS: Xojo 2015r4.1 runs correctly.

Best Regards,

Ren Landscheidt

32 or 64 bit distro? What flavor (XFCE / KDE / etc)?

I have Manjaro Mate-Desktop Edition x64 “15.12 Capella” - September 2015.
Kernel: 4.4.6-1 Manjaro (LTS) - x64 (i7, 16GB RAM)
Dektop: Mate 1.12.1

If someone could direct me where i can find the Crashdumps i could offer more info to help identify the Problem.

Maybe this will help?


Though this isn’t a distro we test against, it does seem to work fine for me. I grabbed the Manjaro Mate 64-bit ISO you mentioned and installed it.

I made sure multilib was enabled, did a full update via “pacman -Syu” and then made sure the additional 32 bit libraries were present via “pacman -S lib32-gtk2” and Xojo 2016r1 runs fine.


I will test the normal TGZ again. perhaps something in my AUR Script makes the problems.
(was just upgrading the PKGBUILD Script for the AUR)

Thx. Will let you know later how it turns out.

Same Error.


Part of the CoreDump

PID: 19885 (Xojo)
           UID: 1000 (twphoenix)
           GID: 100 (users)
        Signal: 11 (SEGV)
     Timestamp: Di 2016-04-05 21:23:52 CEST (37min ago)
  Command Line: Xojo
    Executable: /opt/xojo/Xojo
 Control Group: /user.slice/user-1000.slice/session-c2.scope
          Unit: session-c2.scope
         Slice: user-1000.slice
       Session: c2
     Owner UID: 1000 (twphoenix)
       Boot ID: 89b38b94068148fe83a2a5a8aa514c4e
    Machine ID: bae4778f9fae4b648f6effb364f92bf5
      Hostname: manjaro
      Coredump: /var/lib/systemd/coredump/core.Xojo.1000.89b38b94068148fe83a2a5a8aa514c4e.19885.1459884232000000000000.lz4
       Message: Process 19885 (Xojo) of user 1000 dumped core.
                Stack trace of thread 19885:
                #0  0x00000000ebbbd465 n/a (libRBPluginBridge.so)

GNU gdb (GDB) 7.11
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /opt/xojo/Xojo...(no debugging symbols found)...done.
[New LWP 19885]
[New LWP 19907]

warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `Xojo'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0xebbbd465 in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
[Current thread is 1 (Thread 0xf757e700 (LWP 19885))]
(gdb) bt
#0  0xebbbd465 in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
#1  0xebbbd25d in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
#2  0xebbd19ce in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
#3  0xebbc3e5b in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
#4  0xebbc48c7 in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
#5  0xebbc3ef9 in ?? () from /opt/xojo/Xojo Libs/libRBPluginBridge.so
#6  0xef2ccaa8 in ?? ()
#7  0xf723aee0 in ?? () from /opt/xojo/Xojo Libs/XojoGUIFramework32.so
#8  0xf004609c in ?? ()
#9  0xf1b16573 in ?? ()
#10 0xf7238f36 in listColumnSetter () from /opt/xojo/Xojo Libs/XojoGUIFramework32.so
#11 0x08048e95 in main ()

Hmmm. Don’r really see whats wrong.

Will create a Feedback Report with the “full” CoreDump File later.

PS: Same Error even with the TGZ extracted into my Home-Dir.

PPS: Multilib Packages and ICU and gtk2 (64 and 32Bit) are installed - the only thing not installed is libwebkitgtk1.0.0 or libgtkhtml

Do you have any plugins installed? Did you do a full package update?

We do appreciate the package with the compressed dump attached.


no Plugins (except the Xojo Std. DB Plugins).
at the moment, my main development machine is a Macbook Pro. But sometimes i need to use my Linux PC.

if you like i can give you a download link directly for the Compressed Core Dump (lz4). I’d have to copy the core dump to my Mac first to create an official Feedback Case - no Feedback “Installable” on Manjaro

Yeah, I’d appreciate the link to the dump. Thanks.


here the Link:
Core Dump (Original File)

Version 2 (if above File is not usable or the wrong File):
Core Dump (Extracted via coredumpctl)


any new Information?

Or do you need mor Info from me?

We can’t reproduce the problem on two other fresh installs / updates of Manjaro Mate as I described earlier. It runs fine on each of them. Could you make a Feedback case from your Mac with the link to the coredump?

Ok. WIll do so.

Will also Test in my Manjaro-Mate VM on my Mac.

The Error is on real Hardware.

Xojo 2016r1 runs without problem in my machine.

OS: Arch Linux x86_64
Kernel: 4.4.1-2-ARCH
WM: i3


Create an Bug (https://xojo.com/issue/43338)>]Feedback 43338.

PS: Removed the AUR Package and tried again with an Fresh Download simply Extracted to my Home - Directory – Same Error.

Still have to test in the VM on my MAC

Ok. Works correct in my VM.

So. Now to find out witch “Library” or “Programm” on my Manjaro Linux Main PC makes Xojo Crash.

Hopefully you can find something out via the Crash-Dumps.

So. Finally found the Error.

Got it working (again).

One of my Quick-Fixes for “ncurses” library compatibility was responsible. was not removed / updated correctly.