Xojo 2015r1 cannot open the debugger

Need help, launching xojo abort !
debugger

OS Version ?

Really version 2015r1?
You read the message and looked at the firewall?

This error is from the remote debugger so I have some questions:

  1. Where are you debugging from? macOS, another Windows machine or Linux? Which version?
  2. Is the app crashing on launch, possibly before the debugger connects? You can test this by selecting Run Paused and then launch the app using a CMD.exe terminal. There will be an error.
  3. Because it’s asking about firewalls, make sure that the firewalls on both ends are behaving, outgoing connections on the target and incoming connections on the source.
  4. Is the target a virtual machine?
  5. Are you targeting the correct bitness? That is, 32-bit on a 32-bit OS and 64 on 64?
  6. Do you have the 2015 windows c++ redistributable installed on the target machine?

Do you have a VPN ?

Disable your network card for a minute and re-enable it. See if that solves the issue.
I had the same error, last year, I don’t recall what I did to solve it for good but I do remember disabling the networked card, fixed it momentarily.

1 Like