Xojo 2014r2.1 won't run, crashes loading plugins

First time install. Xojo won’t run. Splash screen comes up, green status bar gets about 1/3 of the way across (to “Loading Plugins”) then it crashes. Comes up with a standard Windows AppCrash Dialog box ("Xojo.exe has stopped working. Windows can check online for a solution to the problem).

Here is what I did:

Installed Xojo 2014r2 which I downloaded a few weeks ago. Got the above crash.
Un-Installed it. Restarted computer.
Downloaded Xojo 2014r2.1 a few minutes ago, installed it, same crash.
Disabled Anti-Virus.
Re-installed Xojo 2014r2.1.
Still getting the same crash.

Any ideas?

System info:

Windows 7 SP1 32 bit
All WindowsUpdates as of 17-Aug-2014.
Internet Explorer 11
Mozilla Firefox 24.7 ESR
ESET Nod32 Anti-Virus ver 7
LibreOffice 4.2
IrfanView 4.3
Other than that, its a “plain-vanilla” Windows 7 install only a few weeks old. There isn’t much of anything installed on this computer yet.

“More Info” from the App Crash:

Problem signature:
Problem Event Name: APPCRASH
Application Name: Xojo.exe
Application Version:
Application Timestamp: 53da569a
Fault Module Name: rbx68EF.tmp
Fault Module Version:
Fault Module Timestamp: 53da56ff
Exception Code: c000001d
Exception Offset: 0001227b
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Too much plugins maybe?
Does it work if you reduce?

Also, which 3rd party plugins are you using, and have they been updated since Xojo was released last year?

First time install. First time ever trying Xojo. So, no 3rd party plugins and no updating/upgrading.

Look in the plugins folder next to the app and remove the ones that are there (the database plugins), and see if that helps your loading issue.

By the way, where is Xojo installed? Is it on the C:\ drive or is it somewhere else?

That worked, thanks.
I tried adding the plugins one at a time. The only one that works on this machine is “ODBCPlugin”. Having any of the other Plugins in there will crash the App.
I thought of something – this is an older machine. Single-Core AthlonXP 3000+ with 2 Gigs of RAM (DDR-400). Perhaps the DataBase plugins require a more modern CPU? Maybe needs Dual-Core, or NX (No-Execute), or some other feature not found on a 9-10 year old CPU.

If that is true, might be a good thing for the Xojo folks to add to System Requirements.

I tried Xojo on another machine (Win 8.1 64bit with Intel i7) and it works fine with all the plugins.

Oh, and to answer your question, it was installed to the default location on the “problem” computer:
C:\Program Files\Xojo\Xojo 2014r2.1

Thanks again for your help.

maybe the ODBC plugin is not compatible to some ODBC driver you have?

But it’s the only one working :wink:

More important than the hardware is the OS. Microsoft changed the Windows memory management significantly after XP which causes some stability issues with programs written with more modern OS’s in mind.

It’s not running Windows XP, it’s an AthlonXP processor.

I understood that and my post was unclear. Typically a machine with those specs would be running Windows XP especially when it is 9-10 years old and Vista is 7 years old.