Xojo 2014 R2.1 vs. 2014 R3.1

I am in the process of deploying an app. I have a head-banger problem.

I wrote the code in 2014 R2.1 on a Mac running OSX… I let my Pro license lapse, and later I signed up for Xojo Cloud. I could not get my app to deploy and was told by the fine folks in customer support that I needed to upgrade to R3.1. I did so and my app deployed fine.

When using my app, the user makes a series of selections from pop-down menus. These selections determine what information is displayed on a new page after the user clicks on the Continue button.

When I run the program on my Mac using R3.1, approximately two-thirds of the time, after have made my selections from the pop-down menus I get a blank page that simply has the web site name in the upper left corner of the page.

I can choose the identical information when running on the Mac, and the same input will cause it to fail two times out of three.

When I upload this same app to Xojo Cloud, this part of the program never works. I always get the page with web site name.

Now, when I go back to 2014 R2.1, it never fails when I run it on the Mac. Of course I cannot deploy to the Cloud because of the problem that led me to this point.

One additional observation, when I run the app on my Mac using Xojo 2014 R3.1 it fails regardless of whether I am using Safari or Firefox. The version deployed to the Cloud fails on Safari, Firefox, and Windows running Explorer.
I cannot test the same situation using Xojo 2014 R2.1. However it works using Safari and Firefox on my Mac.


Odd. Sounds like you should contact technical support so we can dig into this further.

I sent this to customer support this morning.

OK, great.

I figured it out. In my experience it seems that when you get unrepeatable errors, there is usually a memory issue somewhere. I did not realize that images stored in the program use memory whether or not they are loaded. I guess this should have been obvious. Once I started pursuing the memory issue, the pics were the third thing I examined.

I deleted all images from within my app and it works great! Tomorrow I will rewrite my code so that my app will load the images as needed from the server.

Glad you figured it out. On OS X, project pictures are stored in the application bundle and are not loaded until they are used. That’s not the case on Windows or Linux. However, I just discussed this with our engineering team and it could be made to work the same way on Windows and Linux without much trouble. The only change would be that when you build for Windows or Linux, in addition to the app and the Libs folder, you’d have a Resources folder as well that would contain the pictures.

Would that be acceptable to you?

How many pictures do you have in your project and how much space do the pictures in total take up on disk?