Xcode: Unable to install "appname"

I have 2 projects, one is already in the AppStore and one is under construction. The “old” one I can deploy on my iOS devices, using Xcode “Devices” window,
and it installs perfectly using a wildcard certificate. The new app uses the same wildcard certificate (but has a different Identifier of course), and provisioning profile, but I get the very non-descriptive “Unable to install” followed by the app name when I try to add the app to the same iOS device that accepts the “old” app. Does anyone know where I find a log or something that will help me figure out why the new one fails?
Both are compiled from Xojo2019R31 and deployed using Xcode 11.5 running on Catalina.

An error message that only states “Unable to install” is not exactly helpful.

Some people, including me, have had issues with wildcard IDs.

Can you try with an explicit ID?

@Jeremie Leroy : I have tried both; same result.
The older project, when compiled, generates not only the App file, but also an .ipa, a.dSYM file, DistributionSummary.plist, ExportOptions.plist;
I have no idea why the new project does not generate these when compiled.

This is what’s being shown upon entering AppStore Connect today. It’s German but it basically says that no wildcard IDs are being supported any longer and you need to register a new explicit ID for your apps.

Using an explicit ID does not change the behavior; the “old” app still gets a .ipa and the other files alongside the App created on compilation, the new one (using an explicit ID) only compiles into a single app file.

As a very simple other new app did deploy, I decided to copy all elements from the non-deployable Xojo App to a new project,
which then does create the .dSYM file and deploys without any issue. No idea why the other app fails, but in case someone has the same issue; just copy everything over to a new app and that should solve it.