Xcode Simulator Not Working For Me

Hi,

I upgraded my iMac to macOS 10.12.1 Sierra, and also XCode 8.1, running Simulator 10.0, and I can no longer get my iOS apps to run in the Simulator. I can load the app on the device, but not the simulator. I have reset the simulator and that does not help. I’m running Xojo 2016 Release 3.0.

In XCode, I set the simulator to iPad Pro iOS 10.0, and when I try to run it, I get the iPhone 7 Plus simulator instead of the iPad Pro one. The app does not load. It does not load with any of the other Simulators.

I was wondering if anyone knows what may be going on here. What version of the Simulator should I be using? Is there a way to delete Xcode and do a fresh install, so the current simulator for Xojo iOS is loaded?

Any help would be greatly appreciated.

On Sierra with Xcode 8 you need to have simulator open before you try to run debug. That’s all I know though.

Do you have the iPadPro (iOS 10.1) simulator installed?
In Xcode there are dozens of simulators, some for 9.3, some for 10.1…

Iphone7 is ONLY 10.1, so if all the other simulators you have installed are the 9.3 versions, it may pick the only 10 you have

I use Xcode directly, and it by default did NOT install the 10.1 simulators for iPadPro (they are there, but you have to install them yourself)…

Since I wish to still support the iPhone4s and iPad2, I’m not worrying about the 10 simulators quite yet

The Simulator is open. When I try to run it it, I just get the main iOS screen with the icons, but my Icon is not there.

When I open Xcode, I go to Devices and I can see a list of simulators. There are both 9.3 and 10.1 versions of the simulator listed, including the iPad Pro 12.9 inch. Actually there seems to be two versions of the 10.1 simulators.

those are “available”, but not “installed” necessarily

go to PRODUCT -> DESTINATION and that shows the ones “installed”

this is where I choose which simulator to use (but for XCODE projects, not Xojo, but Xcode still needs it installed to use it)

if the issue is on the Xojo side, I can’t help anymore

There is nothing listed in Destination. Its empty. Where are they installed from?

Actually, when I go to Preferences/Components iOS Simulator 10.0 and iOS Simulator 9.3 are checked and look like they have been installed.

This is a known issue with debugging Xojo apps with Xcode 8’s simulators, which has been filed as feedback://showreport?report_id=45711. A workaround until that fix ships would be to keep Xcode 7 installed and switch the command line tools to be Xcode 7 in the Locations section of Xcode’s preferences.

Thanks Joe. The problem is, I think Xcode 7 was overwritten by Xcode 8.0

I’m downloading Xcode 7.3 now. Thank you very much for your help. I will see if that works. I appreciate the help.

I have been burned before. As a matter of principle, I no longer update XCode automatically, until I am sure it works with Xojo.

Good advice Michel. I just thought Apple would get upset if we don’t use the latest and greatest iOS version.

Well, I’m hosed. I’m trying to get iPad Pro screen shots for iTunes Connect so I can submit my app and can’t get any iPad Pro simulator to run. I’ve gone back and installed the older iOS 10.0 versions and no matter which iPad Pro I select, I get an iPhone SE 10.1 launch. Xcode shows all these simulators in the Devices window and Xojo sees them as well.

Feedback Case 45711 doesn’t seem to address this problem. Will this behavior be fixed in Release 4?

Hi Art,

I cannot get the latest version of Xojo to work correctly with the latest version of Xcode. I had to go back to Xojo 2016 Release 1.0 and Xcode 7.3.1 to get my apps to work correctly.

Can you go back to older versions on maybe another machine?

Can you get screen shots from another iPad? The device itself. If you send me those images, I would be glad to resize them for you in PhotoShop to the correct resolution for the iPad Pro. That way you can get them uploaded to Apple.

Start the simulator with ANY simulator.
Then from the Xojo IDE the one selected should launch.
Apple completely changed how the simulator works with Xcode 8 and thats the cause of this.
I expect it will be fixed in R4

Thanks, James. I’ll try my GraphicConverter and Pixelmator fu on iPad images.

[quote=300489:@Norman Palardy]Start the simulator with ANY simulator.
Then from the Xojo IDE the one selected should launch.
Apple completely changed how the simulator works with Xcode 8 and thats the cause of this.[/quote]
Sadly, no. It works correctly with all the simulators except iPad Pro. The first time I run a simulator, the app doesn’t install on the simulator. The second time I run the same simulator, I get the 32 bit warning and then it’s fine after that.

Selecting an iPad Pro simulator in Xojo always runs the iPhone SE simulator.

That’s good to hear. Thanks.

I can confirm that my simulator problems have been fixed in 2016 r4.