Xcode and notarisation after 1st Nov

AppWrapper tells me that I’ll need Xcode 13 after 1st Nov, for notarisation. I don’t actually use Xcode for anything, AFAIK, although I do observe that I have a 2019 version (v11) in /Applications, using up 16GB of space. I suppose I can replace that with a more recent version, but in terms of code signing and notarisation, what does it actually do?

You can read about it here:


Xojo uses Xcode tooling (command line tools) behind the scenes.
Sometimes you manage things IN Xcode to make sure everything is set accordingly to your Apple account.

You may not need it to build apps (albeit I would recommend you try a SwiftUI tutorial or two as it’s next level stuff), but Xcode is where some of the tools that Notary Tool uses are.

I am also re-printing Apple’s requirements for Notarization, even when using App Wrapper.

What does this mean for my late 2012 Macbook Pro which can not run Big Sur? I still use it with Xojo 2019r3.2.

According to this https://developer.apple.com/documentation/technotes/tn3147-migrating-to-the-latest-notarization-tool#

You can still run notarytool on a system all the way back to 10.15. You will need to copy it from Xcode 13 to your MacBook Pro.

The first version of Xcode to include notarytool is Xcode 13. It requires macOS 11.3. It is, however, possible to notarize on earlier systems, all the way back to macOS 10.15. To do this, copy notarytool from a system with Xcode or the Command Line Tools package installed, as described in the previous section.


Apple engineered notarytool to work back to macOS 10.15 regardless of the minimum system version of the product in which it’s contained. This is a special case and does not apply to any other component within Xcode.

Yes, supposedly. TN3147 even has a link to a technote that is supposed to explain that. But the link just takes you to a list of technotes which doesn’t contain one about installing notarytool on earlier systems.

I also just tried downloading Xcode 13 on my file-server Mini that is running Monterey and the App Store refused, saying I need macOS 13, which won’t install on that Mini.

If you use a virtual machine app like Parallels, VMWare, etc, make a Big Sur VM, download the tools into there and copy them to your main machine.


I use VirtualBox, which doesn’t seem to support much of anything for macOS (even in V7), although it works well enough with Linux Mint/Win7/Win10 for testing. There is a machine here running Big Sur, so I might try downloading Xcode 13 there, although if the AppStore still refuses I could move that machine to Ventura.

For downloading Xcode without the App Store…

It still links to Apple, but is helpful for preventing auto-updates.

All you need is to know how to prepare the environment to receive a macOS VM. If you search YouTube, probably you will find some “how to”.

Right, thanks for this. I downloaded xcode 13.4 or so and that runs OK on my file-server Mini under Monterey. I also saw notarytool inside the xcode package. It runs but I’ve not tried to notarise anything with it. That at least means I’m more ready than I was yesterday.

1 Like