Windows launching in Debug Mode problem

I always program in Mac but when I tried to do it in Windows, and when I start a web app in debug mode, instead of starting like this
127.0.0.1:8080
starts like this:
%22http//127.0.0.1:8080/"
And I am not finding where to change


This doesnt happend running Xojo in Mac
Thanks

Hi @Mariano_Poli

What Xojo version are you using? It sounds to me like an old bug that has been fixed already

Update your browser or make Firefox your default. This wasn’t a Xojo bug.

This was a bug fixed in 2020r2 <https://xojo.com/issue/61634>

Unfortunately it wont be fixed in older versions of the IDE so your options are:

  1. Change your default browser to firefox as that doesn’t seem to care about the security change that was implemented by chromium which caused this issue in the first place
  2. Add a button to your browser’s toolbar to take you to http//127.0.0.1:8080/ that you click after the browser opens
  3. Change to a newer version of the IDE >= 2020r2
  4. Make a change to your registry that will decrease the security on your computer to circumvent that change introduced by chromium.

See Cannot run from IDE - wrong URL - 2020 R1.1, R1.2 - #48 by JulianS for a little explanation of the issue and the whole thread for the registry change if you want to go that way.

3 Likes