Windows installer does not allow me to change folder

I tried to install 2023r2 and it will not allow me to change the drive location for the install.

My D: drive crashed last night, and I lost all the data on that drive, so I am going to have to use another drive or use the C: drive for the install, and, due to the D: drive not yet being replaced, I cannot install the latest version of Xojo bc I get this gem: [pic]


Usually, there is one screen in an installer that allows manual selection of the preferred folder.

Also, by default C: is now my preferred installation folder. It’s still not working with this setting in place.

Thanks to all who can assist.

  • Amy Barnes

InnoSetup installers try to remember your last install location based on the app’s GUID. It may be trying to use your last known location. Try uninstalling first, then the installer should offer you the ability to select a location.

I ended up having to pull the box completely offline and move my work over to a new box where it installed fine. I do suggest that the installer do allow for manual folder selection in future releases.