Windows Build -or- Remote Debug

I have an app that I wrote on my iMac, and am trying to remote debug a Window compile on my Win10 machine
This app differs from anything else I have done in that it has a “helper” app that was copied into the build step (.App for Mac and .EXE for Windows)

If I try to use the “Run Remote” it opens a terminal window and tries to run the helper (with no indication of the Xojo part of the app)

If I copy all the parts to the WIndows machine and attempt to run it there I get this message, this included having to redo the copyfiles on the Windows machine

and I get a “Shell Timeout” error

I have no firewall , and no idea what/where any packet filters are (I load Windows like once or twice a year)

Note : the “helper” is called via SHELL

I saw another topic relating to the Ports issue… I did turn off firewall on Win10 machine, and have no anti-virus of anykind
but the issue persists

Perhaps the return communication does not go through? If the remote app is calling back on a different port than was used to start the debug, then the ports need to be open on your mac. I would understand from your quoted message that ports 13897 and / or 60554 need to be open on your mac.

You misunderstand… I get that message when I try to run it LOCAL on the Windows machine. I copied the code and all the resources to Windows, compile it there, run it there and get that message.

My original message indicated I tried two methods… remote debug, and run local… each reacted differently

Have you tried unchecking “Launch executable after receiving” and launch the exe manually after checking that everything copied over?

Again… when I run it LOCAL… I get the long message in my first post.
So I had copied everything manually, and recompiled it directly on the Windows machine.

When I run it via Remote it simply executes the helper and never executes the app itself.

Do you have anti virus software on the windows machine? That can sometimes cause issues.

[quote=400898:@Dave S]When I run it via Remote it simply executes the helper and never executes the app itself.
Right, I’m just suggesting launching the correct exe after Xojo copies it to the remote machine.

Jim… you are not getting what I am saying… that long error message occurs when everything is being done local on the Windows Machine. I copy the source code and all the resources there, and recompile it native…

Basically… it won’t run under Windows at all… but runs fine under macOS

Just a random thought- there is a preference for where the app is built.
Its not going into a mirrored folder or somewhere with dodgy permissions?

No idea… I totally HATE WIndows… so try to keep things as “vanilla” as possible
I created a folder on the Windows Desktop, copied all the bits in there… Compiled it…

Same procedure I do with all other apps where I want a Windows version made available

Well, try fiddling with :

EDIT menu/Options
Building … where does it build?
Debugging… which network interface is it using?

No promises… just working on the basis of ‘if it doesnt work, change things and see what happens’

Wait… your other apps work but this one doesnt?

why would this matter… .as I have explained… it fails on a LOCAL build…

But at this point… I’m going with your suggestion

But I’m removing the helper all together, and writing pure Xojo code that will perform the same functions
there were 10 functions, I’ve already duplicated 6 of them… although that 10th one will be tricky

Solved the problem by removing reliance on the “helper”… I have managed to code all the things the helper did directly into pure Xojo code, and to be honest I don’t notice any real speed difference.

It runs great under macOS, and under WIndows via the remote debugger.

I couldn’t replicate the problem so I couldn’t come back with any pointers. Glad you got it sorted.