Windows App (Explosion Generator) doesn't run


Explosion Generator by Deep Blue Ideas instantly stops working after starting it on Microsoft Windows 10 Pro 10.0.19045 Build 19045.

Restarting it throws errors like:
(pressing OK leads to an endless stream of similar errors)

Trying to install redistributables recommended in Unable to start app on Windows - #2 by Christian_Schmitz results in setup failed

It’s missing some things from the Libs directory. BevelButton is in a DLL

First check whether you missed files in Libs folder when copying.
When all files are there, use an app like Dependency Walker to check each DLL for missing other DLLs.

How have you installed it?
You might see this if you tried to run it across a network

Does the shortcut have the right working directory?
Does the folder with the EXE contain the libs folder and the resources folder ?

I am on windows 11 and i also see this error. it happens in debug run as well. I have copied the complete folder as i do for all installations.

I have seen the same thing with DateTimePicker. There’s an issue with this build for Windows users.

Wow, thank you all for responding so quickly and helpfully.

There is only one 33.4 MB exe.

There is no Libs folder. I’m not a dev, so I wouldn’t know anything about missing files.

The HEX looks like this at the start (perhaps this clarifies something about embedded dlls or something?):

I tried using GitHub - lucasg/Dependencies: A rewrite of the old legacy software "depends.exe" in C# for Windows devs to troubleshoot dll load dependencies issues. yesterday but it resulted in an out of memory error and I couldn’t really figure out the output (it was dumping binary?)

Dependency Walker seems to have failed:
Error processing the module’s imports table.
Warning: At least one module was corrupted or unrecognizable to Dependency Walker, but still appeared to be a Windows module.

I installed it by extracting with innoextract and also via Sandbox but both just extract one Exe. The installation method adds an uninstall exe. There is no shortcut, running exe directly, I simplified path and filename to not contain whitespace too. There is no libs/resources folder next to the exe.

Sunil_Abraham, Wayne_Golding thank you for checking/confirming/reporting!

I only now realize the developer (I assume) @Wayne_Hawksworth is a user here. ping :slight_smile:

I’m guessing they have the missing DLLs (or something) installed system-wide, so that on their system the app works fine. I’ve had such issues with Pyinstaller-made apps. My solution was to get a vanilla Win7 installation in Virtualbox and forcing myself to to test the exe before publishing/updating (not a lot of fun but oh well).

You are in the wrong place. You need to contact Deep Blue Ideas.

1 Like

He never visited the forum. The User has been most likely carried over from an old Forum.
His last Tweet was 11 years ago and Explosion Generator has been released 8 years ago and a v3 is in develeopment since then. I bet it’s safe to say the App is not only outdated, but dead.

You are trying a compiled app?
Then either it was done in an old version of RealBasic that doesn’t support Win 10, or the installer was set up badly.
My money is on the former, since it works in Windows 7.
You can try right clicking and running in compatibility mode under Windows 10?

Sunil Abraham
I am on windows 11 and i also see this error. it happens in debug run as well. I have copied the complete folder as i do for all installations.<<

Are you running the same app as source code???

@Wayne_Golding There’s an issue with this build for Windows users.

Are we all talking about the same thing?
To me, I read the OP has gotten hold of an old app that wont run.

Sunil and Wayne seem to be saying that nothing works in ‘this build’ - what build? Are you guys talking about the most recent Xojo?

Comp Matt is a customer of Deep Blue Software, not a Xojo developer.

Yup. So he has an old app that needs windows XP or 7.
It may run under compatibility mode.

I don’t understand what the ‘me too’ replies are about - is there some issue with current Xojo too?

It sounds like developers using a modern version of Xojo who use the DateTimePicker control seem to have some kind of build error on Windows. Such an issue would be unrelated to this issue, as this is a compiled app that allegedly worked once.

I don’t recommend using DateTimePicker, I tried it and it was clearly incomplete.

That’s awesome. I had tried Win7 compat mode and that just throws the errors from my original post.

But in my Win 7 virtual machine, Explosion Generator just works! I think that’s hilarious because its website specifically states that Win 8.1 is the minimum requirement.

So the workaround for now is: use Windows 7, maybe Win 8.1

And therefore no one should try to help him? Nice.

No, it’s that we can’t. We can fix problems with source code.

Missing DLLs require you reinstall the program from the source.
If someone were missing DLLs from one of my apps, I would hope you send them to me.

I would sincerely hope that you don’t provide someone claiming to be missing DLLs from my applications with any DLLs. These are files the original installer puts in place. That should come from the developer, not any other source.




1 Like

Thanks, but she was trying to imply that I didn’t want you to have an answer so I need to stand up for myself.

1 Like

Well, Jeff helped him by telling him that it works in Windows 7. And the community helped him by educating him as to the difficulties involved in solving his issue. That’s how we do here, this isn’t StackExchange.

In my case a DateTimePicker control created the issue see which has been fixed for the next beta.