Why would the Tab Key not produce a list of public Properties and methods?

Hello all,

I hope this is not repetitive, but I bounce from one IDE to another doing all sorts of different stuff. Tonite I am back on Xojo, and am wondering why the Tab key does not show a list of public properties and methods.

In a method I am doing this; this is where I am wanting to see the list appear:

Dim IW As New clsIncomingWirelessData
IW.  <=====  nothing comes up

The properties of the class clsIncomingWirelessData

Public Property Data as String
Public Property Address as Integer
Public Property ModuleTypeNo as Integer
Public Property Protocol as Integer
Public Property Startup as Boolean = False

There are many more properties just wanted to show some examples…
Appreciate any responses!

Thank you,

Autocomplete isn’t perfect. Sometimes it can get confused depending on how deep nested within things.
If you can reproduce the issue in a basic test project, submit a bug report.

This is going to seem odd but try with your code as

Dim IW As clsIncomingWirelessData
IW = New clsIncomingWirelessData

Maybe not the issue here, but I often find that if I have a syntax error in a line somewhere between the Dim statement and the line I’m working on, then the autocomplete may not come up. It’s a good indication that I should hit cmd-K (ctrl-K on Windows) and see what I’ve screwed up.

Hi Guys!
Thanks for your replies!
@Norman, I did that too, and just did it again to be sure.
@Robert, it checks and compiles without error.

No change. Anything else to look at?

Try it in a simple project.
Try it in a previous version of Xojo.

I just tried the same setup in a simple project in Xojo 2016r2.1, and I get the autocomplete list of properties.

Hi Tim,
The class, while it should stand alone, is also part of a Module. I can try in another version, have not done that yet but can certainly try.

If it means anything, which I think it should NOT from an IDE standpoint, the same class is instantiated as a property within other classes inside of the Module. From an IDE standpoint, it is just a really big PIA to have to work around this limitation.

From a compilation, working POV, the code is fine. Its simply is providing a huge PIA to code within the IDE.

Thanks for the reply Tim,

Include the module name when you declare the variable and everything should work as expected.


Instead of just


Hi Jason.
Tried that too. Retried to be certain that am not crazy and getting everyone else following along!
It did not work.

I also tried in a method within the Module too. Just to see if the IDE would recognize it.
What I did not do,but will now, is to restart the IDE and see if that has any effect.

Thanks to you and the other for the responses!

Nah… makes no difference; after cleaning the temp folders/files and rebooting etc, the properties are still not shown using the Tab key.


What’s the scope on that class?

Hi Greg.
The scope is Public.

Try making it global. AutoComplete sometimes has issues with scope.

Hi Greg.
Tried making it Global, in combination with both the way I originally instantiated it, and the way Norman suggested. Same result, not cooperating.

Dim IW As New clsIncomingWirelessData
Dim IW As clsIncomingWirelessData
IW = New clsIncomingWirelessData