Xojo is using iOS (and presumably Android) controls with a “Mobile” prefix, e.g. MobilePushButton.
But after reading Norman’s post about compatibility flagsI have to ask:
Could they not have simply called it PushButton by putting it in a module called Mobile, and setting the compatibility flag to mobile only?
Would that not have avoided the Mobile prefix for all controls (so PushButton is PushButton EVERYWHERE) and made code reuse MUCH easier?
Seems a no-brainer to me, so why not?
I also recommended several time to do whatever is needed for the compiler to have alias names.
e.g. Button could refer to WebButton, DesktopButton, MobileButton and we never see those names as we only use Button.
I do not understand why Xojo renames events (breaking backwards compatibility and many years of accumulated source code) but then leaves out the simplest but very effective improvements to code reuse.
Why simple when we can do complicated?
It boggles the mind
I would love type aliases!