Why does Xojo CEF bindings work differently from other CEF binding implementations?


I tried this a couple of years ago, but Xojo was running CEF1 in the HTMLViewer back then.
But the release notes of 2018r3 from august clearly state that HTMLViewer on Windows with Webkit enabled uses the ‘latest’ CEF3. Nice!
The ‘latest’ back in august was released on 08/03/2018 and was version CEF 3.3440.1805.gbe070f9 / Chromium 68.0.3440.84

So, I downloaded the Sample webbrowser build with that version (that one’s written in C++) and try to fire up a WebGL + ASM.js example from a 3D engine I use in my free time: Works perfectly

I drop a HTMLViewer with Webkit renderer: Error

I thought, ok, give them some slack, and tried some CEF versions before, all worked. The oldest version I could test was May 2016, and that still worked.

Why doesn’t this work in Xojo, what is so fundamentally different, and ofcourse, can this be altered? I guess it has something to do with WebGL, is there a way to enable this etc?

I uploaded the sample WebApp for testing here: https://chromiumembeddedframework.000webhostapp.com/Terrain.html (a bit slow, free hosting)

Thanks for any insights or help!

Xojo uses CEF build 3359 as far as I know.

And I presume they certainly don’t have all extensions enabled.