What Could Cause this linker error in 2019R1... Plugin or xojo?

I have an app started in 2019r1 and worked in in 2022R1. I meant to keep it 2019R1 compatible. And i did not use any features not in 2019R1.

the project opens in 2019R1 but when I go to run I get a linker error:

Linking Executable
ld: file not found: /System/Library/PrivateFrameworks/UIFoundation.framework/Versions/A/UIFoundation for architecture x86_64

The problem is if I compile it in 2020R2 there are issues running on Mac High Sierra that I don’t see on Monterey so I wanted to compile in R1 and see what happens on the high sierra machine.

I copied and pasted all the code/widows etc from the 2022r1 project into a new 2019R1 project and still get the same error.


Isn’t that the error when you try to compile desktop apps with Xojo older than 2019r3.2 in newer macOS?

You can try to compile in 2019r3.2 or patch your Xojo 2019r1.

1 Like

it IS patched and works OK on Monterey for other projects

Somehow I wound up with 2 versions of 2019R1.1 on this machine and only one was patched… and of course the wrong one launched!


1 Like