weird autocomplete

I installed 2017r21 recently, and I noticed some weird autocomplete in the IDE
it’s like the autocomplete takes into account the superclass, and don’t know the actual class I’m working on.

does anyone experiment the same thing ?

seems to happen when you duplicate one method, and then change the data type of some variable,
then the autocomplete on these variables does not seems to work correctly.

for instance…?

omg it’s awful to work with xojo with almost no autocomplete …
I restarted xojo and it’s still the same,
all the extends methods I made still work, I can compile, but all the autocompletes of these extends methods in the IDE do not work.
what can it comes from ?

restarted the mac, still the same …

reopened my project with 2017r11 and the autocompletes works as before …
what can it be ?

same line of autocomplete, same project opened under 2017r11 is ok, but bad with 2017r21

It looks like the problematic methods all have attributes. Could that be the problem?

What is the property type of “ch”?

ch is a string

thought about that too, but no the last method “tovnlinkaction” has no attribute and doesnt appear on 2017r21

I tried to make a small project, but this weird behavior does not appear.
I have other apps with common external modules with this one I’m working on, and all of them have this weird behavior.

Autocomplete in the latest version does not work if the extends method is in an external module.

Import it into the project and it will work.

I believe that this has been reported.

it is the case: thanks Simon. it’s really annoying ! :frowning:

It has been reported, verified and fixed.

In a future release it should work correctly, I hope.