WebPopMenu not changing size in Linux

Hello all,

Is there a reason why a WebPopMenu cannot be sized in Linux? I have tried several things including manually setting the height but each time, it appears the same on screen. I started with a Height of 20, same as on my windows machine. Way too big. So I cut it down to 18, then to 10. Each time in debug build, it appears the same on screen. I also tried turning on/off HiDPI, no change there either.

Finally, when trying to manually change it in the properties/inspector, I would type a 1 then a 0 but all I got was a 0. I could not manually change the size, only in code. The object position is not locked either (the top and left lock icons are selected in the inspector tho).

Any ideas why this is happening and how to fix it?


WebPopupMenu renders a native OS control in browsers, and if the underlying control can’t be styled, it’s possible that you can’t change the height.

Hi Greg.
Interesting. So to be clear, if the browser is the same (firefox in this case) is the same in both Linux and Windows, it is Linux that is stopping it from being rendered differently/controllably - correct?

Thank you for your response Greg.