Webimage pressed Event not fired on device with touchscreen and mouse

Pressed Event is not fired in 2021R1.1 (Works in 2021R1)

feedback://showreport?report_id=64536

Sample Project and video in Feedback case.

FYI: works at least on macOS. However still missing that the cursor will change to show it is clickable.

I have no windows10 env currently at my hands. Perhaps some one else can try it out for you on windows.

1 Like

It is a Windows browser issue (chrome and edge tested). Tried it on my MBP M1 (chrome and safari), works.

From windows to macos (app running on macos, doesn’t work).

Tested with several windows systems, same bug on every windows pc.

1 Like

If i switch to developer mode (in edge or chrome on windows) and select a device, event fires.

Video added to feedback case.

1 Like

For me it works well on Windows 10 with Google Chrome or Microsoft Edge.

Still not found any windows (10 or server 2019 or server 2016) which works.

Please try:

https://debug.living-it.info/ (click on the bug and see if label changes to ‘image clicked’)

PS: And thnx for @Tim_Parnell for great Lifeboat which makes it so easy to setup a host in 5 Minutes

Brave (chrome) on windows 10 works.

Make sure you clear cache of the browser SHIFT + Refesh Icon.

@DerkJ no … even not in private mode. Also tried with 2 Windows Tablets from my wife and neighbor (home office test equipment is limited ;-))

Mine Chrome and Edge on Windows 10 64 Bits works fine.

Crazy … same app build with 2021R1 works here. 2021R1.1 doesn’t.

Use a desktop computer?

Something has changed in clicking for better experience with certain touch devices (as far as i can remember) in 2021 R1.1 maybe this effect is a bug you are seeing on a touch device?

@DerkJ Hit … you got it !

No i am using an Surface Laptop with external monitor. But it has a touchscreen (and this is the cause).

If i disconnect the Monitor the event is fired if i touch the screen … not if i click it. Same with a surface tablet. If i touch the screen everything works, clicking doesn’t.

So on an windows touch enabled device mouse click doesn’t work. I think xojo detects touch enabled and disables the mouse click.(even if a mouse is there and also if the touch screen is off (because of external Monitor).

The error occurs in connection with Windows devices that have a touch screen.

If the device has a touch screen, the click event is not executed via a connected mouse. Even if the touch screen is not active. (Because notebook in docking station).

All devices I have tested have a touch screen.

A lot of Windows Devices are touch enabled these days … so this is (for me) a criticial bug. Sh… I need 2021R1.1 because of the bug fixes in Web 2.0. Any chance to disable the touch optimization of the pressed event ?

1 Like

Too bad we can’t edit the original post on Feedback Cases to update it with the information you found. I hope Robin and the team read all the information before start testing.

In short, the only way to reproduce this is to have a Windows touch device and use the mouse to click and not touch, right?

2 Likes

Right.

2 Likes

Maybe is easier for Robin and the team to ask your case to be closed and open a new one with more concrete information (latest finding). Maybe.

Just add more info there.

With Microsoft Edge 90.0.818.42, it did not work.

With Microsoft Edge 90.0.818.46, it works.
With Firefox 88.0, it works.

On Windows 10 X64 19042.928

The problem appears to be related to the browser, with newer versions working.

Still not working on Microsoft Surface Laptop 3

Also Firefox 88.0 is not working.

I hope there is a option to disable xojo touch optimization ;-).

I fired up my Surface Laptop 3 (same Windows version as before).

With touchscreen off and touchpen processor off (in device manager), it works with Microsoft Edge 90.0.818.46.

Turned on touchscreen. Works with screen and works with mouse.

Turned on touchpen processor on: does not work either on touchscreen or mouse.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.