webHTMLViewer Stuck??

Hi all, Ive put this in the getting started area because Ive never used this control before.
And to be honest I feel like a newbie all over again
I must be doing the most dumb ass mistake because I cannot get a webHTMLViewer working in its simplest form.

i.e. New web project, drag a webhtmlviewer on to the page. set the default url in the IDE to
and run…

I get the outline of the control and no google site?
Im using 2015 R4, and tried 2015 R1 with no plug in incase it was my setup.
I’m on a mac with El Capitan

So what am I doing wrong??

any direction would greatly be appreciated.

PS i used HTMLViewer1.LoadPage and that worked. i.e. I had some simple html appear in the control.
I just cant get HTMLViewer1.Url to work.

Thanks In advance
Regards James

Cannot load an SSL site from a non-SSL site unfortunately. Google no longer serves itself non-SSL. Your app would have to behind SSL in order for that to work.

Double check that though, “https://www.google.com” MIGHT work depending on browser - works for me on Safari but that’s not guaranteed elsewhere.

thanks Phiilip
I just tried a different site and of course it works.
Murphy’s law about trying new stuff :wink:

Yeah the webHTMLViewer is just an iframe so it has to follow all the same rules unlike desktop HTMLViewer which is a hosted WebKit instance.

again thanks Phillip
Hope you had a great Xmas and New Year
2016 looks like its going to be an exciting year for you.

There’s also the fact that Google never really liked being in an iframe anyway you may run into other sites that do this as well (including Xojo web apps depending on their security setting).