WebFileUploader Not Working With Camera on iOS 12 Devices/Mobile Safari

The WebFileUploader doesn’t seem to be working with Mobile Safari on iOS 12.

Testing on multiple devices (iPads, iPhone) using the example project included in 2018r3:

/Applications/Xojo 2018 Release 3/Example Projects/Web/Controls/WebFileUploader.xojo_binary_project

All devices running iOS 12.0.1 or 12.1

• Open site on iPad or iPhone in Mobile Safari
• Click the “+”
• Select “Take Photo or Video”
• Click “Camera” button
• Select “Use Photo”

Expected result: File information appears in listbox

Actual result: nothing happens

Apologies if I’m missing something obvious.

Could be an iOS bug relating to taking the photo directly. Have you tested with a photo in your camera roll? Does Safari have camera/camera roll access? Once you can confirm it’s not Apple’s bug, file a feedback case explaining how it’s not Apple’s bug. Xojo’s been more than happy to close bugs that are theirs as Apple’s lately, so be prepared to defend your ground.

Thank you for the the reply Tim.

Photos in the camera roll and other files via the “Browse” option work/are accessible via the popover menu which appears when you press the WebFileUploader’s “+” button. (they appear in the control when selected)

Put another way, everything works except taking a picture with any of the built-in cameras on the iPad/iPhone.

Some other notes:
• The “Camera & Microphone” access is turned on for Safari
• I’ve tried with "Private Browsing " on/off
• I tried the project on an Android tablet in Chrome; which worked as expected (picture name appeared in list)

So this feels more like the controls access to the camera is just broken in Mobile Safari.

I’d appreciate anyone else trying this out to confirm. Again, I’m using the example project for the WebFileUploader included with Xojo so it’s pretty easy to test out.

I can confirm. Uploading existing photos works, using the camera itself has no effect

Thank you for testing Steve.

If anyone else has any other information/insight, please share.

Is there a bug report for this?

Was waiting to see if anyone else had any hints/pointers Greg.

I’ve created a feedback case now. It’s located here: <https://xojo.com/issue/54115>

@Greg O’Lone feedback case created, it’s:


Please let me know if there’s anything else I can do to assist; happy to troubleshoot/share more information.