WebFileUploader.FileCount doesn’t reset on Linux

I have taken the WebFileUploader example and put it into a dialog of a webpage.
It uploads fine, but when you close the dialog and open it again to upload a new file, it crashes because the FileCount hasn’t been reset since last upload.
This only happens on Linux. I have tested it on Mac and that works fine.

Can anyone confirm this? Is there a way to work around this?

Here is my test-file:
https://www.dropbox.com/s/xh7r4h02fh3k6xr/WebFileUploader_test.xojo_binary_project.zip?dl=0

Please fill a feedback case.

And is it the same dialog object or a new one each time?

Okay - I will.

It is a new dialog object each time:

Dim ud As New uploaddialog ud.Show

Just found out - if I reuse the dialog the problem doesn’t occur.

But that’s not the answer. Please file a bug report anyway.

Okay, I have done that now.

feedback://showreport?report_id=53617

Apparently it is not only on Linux - I get the same behavior on Mac.

What platform is the Browser running on?

Oh, and what version of Xojo are you using?

@Alexander Marthin : I just tried your project running on Ubuntu 14.04 and had no errors and no crashes. I did the steps exactly as you outlined in your Feedback report.

Using Xojo 2018r2 on macOS 10.12.6, browsing with Safari 12.0 (12606.2.11) and Chrome 69.0.3497.100

The only difference might be that you had your project set to CGI, whereas I set it to Standalone.

Yes, I am sorry - I have confused myself. I just tested it using Xojo 2018r2 on Mac and Linux, and it works on both platforms.
The error only occurs using Xojo 2018r1.1.

My apologies. Is there a way for me to cancel the bug report or will that be done automatically?

I think Greg or someone who looks like him can mark the bug report as “fixed” or “ignored” or possibly “never ever want to see this again.”