WebFileUploader does not upload identical files

It seems like the WebFileUploader ignores the last file(s) that are uploaded if the files have identical names, i.e. trying to upload the same file two times.

Steps to reproduce:

  1. Create a new web project
  2. Insert a WebFileUploader object
  3. Create FileAdded event with the function Me.Upload()
  4. Create UploadCompleted event with the function MsgBox (“Upload complete”)
  5. Upload a test file -> it works
  6. Upload the same test file -> it doesn’t work
  7. Upload a file with a different name -> it works

Anyone seen this before, or know any workaround?

This should be fixed in the current beta. Have you tried that?

I just tried the 2018R2B12, and the bug is still there.

Please file a bug report with a sample project against the beta ASAP.

I’m unable to file a bug report as Feedback on both macOS and Windows have dimmed the “Create new case” item in the menu.

(and I have checked that I’m logged in, and that I have a valid licence)

You have to search for something before you can create a case.

Thank’s Tim :slight_smile:

Feedback case filed: #52744

Fixed in 2018R2B15 :slight_smile: