Web MySQLCommunityPlugin.so Deployment Issue

Hi, I have been trying for 2 days to implement a working app on Linux CentOS 6 without success. I have tried to resolve this with the help of another Xojo developer and am now desperate for further help. I usually get the error:

Unable to launch application 'APP' on port nnnnn

The web app will only launch if I remove MySQLCommunityPlugin.so from the “APP Libs” folder. However, this is a database app and needs to access MySQL.

I have tried compiling the app with various versions of the MySQLCommunityPlugin and uploading the new version but nothing changes. I always make sure the unique reference identifier is changed and any previous processes have been killed. I have made sure the 32-bit libraries have been installed, the items in the cgi-bin folder have the correct types and permissions. I have also tried using the new 2013 r3 version available today, without luck.

The XojoTest app runs successfully - but that does not use the MySQLCommunityPlugin.so file.

Please can you help? I can’t find anything on this in the Feedback app or in the forums. Any help you can provide will be gratefully received.


Well, simply take the .so file and use the ldd command.

ldd MySQLCommunityServer.so

there you see which libs are needed and you may see which is missing.

Thanks Christian! I get this from the ldd command: I see something is missing but I have no idea what is missing and I need to do, do you know?

linux-gate.so.1 =>  (0x00907000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00e71000)
libz.so.1 => not found
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00354000)
libm.so.6 => /lib/libm.so.6 (0x00497000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00642000)
libc.so.6 => /lib/libc.so.6 (0x00718000)
/lib/ld-linux.so.2 (0x001ff000)


install libz package?

Thanks - I just did a yum install zlib.i686 and the library is now there. My app now launches!

Many many thanks! I would have never been able to sort this out without your help.

Best wishes, Eric

yum install zlib